Mentioning @trust_level_0


(Alex Armstrong) #1

I just sent a message on my system mentioning a sub-group (@foo), as well as @trust_level_0. Another group (@bar) is set to “watch first post” on that category.

What I thought would happen: everyone in my system would get the message.

What actually happened: only the members of @foo, @bar and those who have enabled “mailing list mode” received the message.

Here are the settings of the trust_level_0 group:

Any ideas?

I’d like to get this message out ASAP to everyone, not sure how to approach this now :slight_smile:


Add a label to notify all users
Who gets notified when you reply to a topic that contains an @mention?
(Alex Armstrong) #2

So I tested a some simpler messages in my development Discourse, to remove the ambiguity caused by my original case.

Posting a topic and mentioning @trust_level_0 doesn’t work, as of the latest version of Discourse.

Apparently, this has been brought up before:


(Alex Armstrong) #3

OK, I figured most of this out. (Isn’t realtime reporting fun? :wink: )

Apparently, there’s a setting called max users notified per group mention, which (you guessed it) limits the max number of users that can be notified by a mention.

Setting it to a high value like 9999 (we only have 400 users) looks like it works as expected.

The admin screen clearly describe what this setting does:

Maximum number of users that may receive a notification if a group is mentioned (if threshold is met no notifications will be raised)

However, this isn’t mentioned when you get the just-in-time warning:

@team, I propose that this is a UX bug. If the number you’re mentioning is higher than the max users notified per group mention setting, then Discourse should extend the above warning with some copy like this:

By mentioning @group_name, you would normally notify X people. But because this exceeds the maximum number of users that may receive a notification, no notifications will be raised.

I’m not sure how exactly multiple group mentions are handled, so I can’t offer suggestions in that case.

In related news, messaging @trust_level_0 also doesn’t seem to work – it only sends 10 messages and then ceases. Is there a similar setting that prevents messaging users? I wasn’t able to find it.


(Dean Taylor) #4

Perhaps “max allowed message recipients” but I think this defaults to 30.


(rizka) #5

I agree that the warning is very misleading. We have used @trust_level_0 to reach out to our large userbase quite a few times over the time period of nearly two years. Only very recently we learned that nobody received the notification we wanted them to get. See @ljpp’s post: