Missing "New" and "Unread" buttons in navbar


(Watercolor Games) #1

Alrighty…Not sure if I’m dealing with a single bug or two bugs at once here or even how to reproduce this issue. When typing the name of this topic, I got suggested to read this topic among other (unrelated) ones… but that’s a feature request and from what I can tell that feature did not get added yet. (and if it did, I didn’t get notified of an update.)

Ever since setting force https in my admin panel today, the “New” and “Unread” buttons stopped appearing in the top menu on my account. Other users seem unaffected, and the two buttons are enabled in the admin panel.

I disabled the force https setting thinking it’d help (I don’t need that setting anyway, I got Discourse running behind nginx which is configured to force https anyway). I then attempted to clear my browser cache AND purge my CloudFlare cache. Nothing helped.

So now I have a home page that looks like this.

I can get to the New and Unread pages by going to them directly (or setting one of them as my user home page)


And finally, sometimes if I navigate to “Top” or “Categories”, I can get phantom “new” and “unread” counters to show in the menu, like this.

However, that post counter is fake. Clicking it does NOT show me two new posts. Instead, it does this.

No new posts, but all of the sudden I have 2 unread posts (I’d like to point out that this entire time of me navigating through these phantom links, the “let’s get this discussion started” banner stayed at 16/30 posts, and only increased to 17/30 after a friend posted in the “Introduce Yourself” topic after I took these last few screenshots. There were never any new posts besides that one.)

And as you can guess, clicking that “Unread (2)” button just yields a “You have no unread posts” screen.

I am hoping that either:

  1. This is a known bug and a fix is coming.
  2. Someone else has experienced this and knows how to fix it or what went wrong.
  3. It’s a simple Chrome caching issue (wouldn’t be the first on my site while installing discourse) and it’ll magically go away the next day or not happen when I’m on a different computer or browser.

I couldn’t even tell you how to reproduce this issue for yourselves. I don’t even know how I caused it or what I could’ve done to enable a feature like this (if it IS a feature and not a bug). I don’t even know if this is an issue with my CloudFlare or my Nginx (or even Discourse itself) because no one else on my site’s having this issue. The only thing that even remotely points to causing this is the force https setting…but that just seems like a major coincidence.


(Jeff Atwood) #2

Correct, those nav elements no longer appear unless there is something actually new or unread to read there. Otherwise users are invited to click on something that will bring them to an empty set.


(Watercolor Games) #3

Well, what’s causing these phantom post counters then? And is there a way to disable this feature (even if it’s just at a user level?) I honestly prefer having them always there rather than only showing when there’s something there to read. Because in this case, even if it SAYS there’s something to read, there actually isn’t. For me personally even if there’s phantom stuff going on I prefer to have both the buttons always visible and sometimes being derpy rather than showing up randomly when they’re not supposed to.

Furthermore this feature wasn’t there or active until (coincidentally) I activated force https. What the heck else did I accidentally enable?


(Sam Saffron) #4

Oh I wonder, do you have any scheduled posts ? They are a major culprit for phantom counts we need to fix.


(Arpit Jalan) #5

Can you try disabling CloudFlare acceleration on your forum and see if that fixes the issue?


(Watercolor Games) #6

That I made? Nope. But it seems rebuilding the install with ./launcher rebuild app got rid of the phantom counters.

I’m in Developer Mode, so it’s not caching at all. Enabling Developer Mode didn’t fix the issue though.