Mobile "topic wrench" doesn't display when there's only 1 post in a topic


(David Taylor) #1

As a side effect of

It looks like the wrench follows the same logic as the “pagination widget” - it doesn’t display for topics with only one post. That makes it impossible to do things like “set topic timer”, or “make unlisted” etc. when on a mobile device.

Repro: as an admin, make a PM to yourself. There’s no wrench


(Sam Saffron) #2

Confirmed:

@eviltrout this is yours


(Robin Ward) #4

I removed it intentionally because there was no good place to display it anymore. Normally it would appear at the bottom - but at that point why not use the drop down that’s right there?


(Sam Saffron) #5

yeah, it is missing from the bottom topic controls, there is no way of getting the wrench, now. We got to add the option there.


(Robin Ward) #6

Can you be more clear about why the drop down is not sufficient?


(David Taylor) #7

It doesn’t have the same buttons. E.g. where is the “Set topic timer” button?


(Sam Saffron) #8

It is missing, admin from the list of options, should be either above Invite or below Assign


(Robin Ward) #9

I’d rather add all the same options to the drop down than have two slightly different menus.


(Robin Ward) #10

I went in to change this and realized just how different the drop down was from the admin menu! Instead what I think is a decent compromise is to not hide the progress bar on mobile topics, even if they’re short. That way, there is a decent looking place for the wrench.

The downside is you’ll see 1 / 1 topics but on a small screen it’s not so bad since you probably have to scroll to get to the bottom of the post anyway.

Let’s try that out and see how people feel.


Admin wrench invisible on single topics
(Jeff Atwood) #11