Moving posts to new PM did not invite all participants

Hi all,

let me just preface the new interface for moving posts around is great. :sunny:

But, I got recently burnt when moving posts from a topic to a new PM. I moved around 6 post from 3 different people (one of them me), but only two of them got invited to the PM. What tricked me was that the third person’s avatar was actually listed as a poster in the footer below the OP…
image

but I did not notice that she was not in the list of PM participants just bellow

image

Can anyone reproduce this problem? Or did I hit some weird edge case?

Thanks!

1 Like

I can confirm this. Today I changed a public topic with about 5 users and 9 posts. Only 2 of the users, as well as myself were invited.

1 Like

Can you repro this @rishabh?

I could not repro this on my dev install with a topic that had mods, admins and regular users.
I’ll now test on this topic itself, sorry about the notification(s).


No repro on this Meta topic too :arrow_down:

Screenshot%20from%202019-02-09%2018-13-21

@JagWaugh @danekhollas Can you think of anything that’s possibly unusual about these users or topics that might hit an edge case?

5 Likes

Okay, I just reproduced this on a topic on try.discourse.org:

There were 10 participants in the topic but only two of them (the originator + the person performing the conversion) were in the list of participants after converting to a PM.

Screenshot%20from%202019-02-09%2018-28-34

3 Likes

No. The topic wasn’t particularly old, or long, and it didn’t have all that many users.

Here’s the summary:

Only the originator of the topic and myself were included in the PM.

I can’t remember now if I selected all the posts separately, or did it at the topic level - in any case all of the posts were in the PM.

Not really :frowning: In my case all three users were mods. And I was moving from a post in a private category (restricted to certain group).

Try data and users are so old, not entirely sure that is a valid repro unless the original topic was also from 2014 or older?

1 Like

Definitely not, topic was from this month. Our our original install is fairly old, 2014/2015, but the user in question was created in 2017. We are currently at 2.2.0-beta+100, but I did not notice any commits related to this feature since then.

Thanks for investigating!

Can you try varying the selection method @rishabh to see if that makes any difference?

2 Likes

In my case I only selected certain posts, not sure whether individually, maybe I clicked Select+below.

1 Like

I now have a consistent repro on this topic which happens ONLY if you follow these steps:

  1. From the topic wrench, click Select Posts…

  2. click select+below on the first reply (because the first post cannot be selected to move with this UI, that is only possible when doing a topic level move)

  3. move to new message

The posts were moved correctly but @danekhollas wasn’t invited to the PM even though he has four posts in this topic. Note that he is the OP and we couldn’t select the first post, maybe that’s the edge case.

Screenshot%20from%202019-02-11%2011-21-27

6 Likes

Fixed in

6 Likes

This may need to be backported to stable?

1 Like

Agreed, backported to stable branch.

7 Likes