Moving the server

Hello, everybody

I am in the process of moving our discourse server to a new location.

On old server I did:
discourse backup
then copied the latest backup file from container to host system
copied it to new server

then on new server:
started the discourse container
copied backup file into it
did discourse restore (went fine)

Then I possibly made a mistake, I’ve tried to restart discourse container using docker restart, without rebuilding it.
when I opened it in browser, it was just showing me five blinking dots.

I tried rebuild the app, using ‘launcher rebuild app’ command. same five blinking dots.

what am I missing?
thanks a lot in advance.

Did the rebuild finish successfully? Is the container running?

You might try running Discourse Doctor:

sudo -s

That should give more information that could help.

The rebuild passes just fine. And no problem is found by discourse-doctor.

What happens when you try Safe Mode?

Was this using the standard install or some other method? Did you happen to look at the site before restoring the backup?

Look at the javascript console. It’s probably a broken theme, but could be a broken CDN configuration if you have a CDN (or S3). If you don’t have CDN, then safe mode will probably fix it; then you can find the theme (or perhaps plugin) that’s the issue.


starts just fine if I disable unofficial plugins.


how can I take a list of plugins installed?

Mostly, remove the ones that don’t come from github/discourse/ in your app.yml and then rebuild.


Though if you share a list of your plugins here we may be able to spot one with a known issue, which may save you some time. :+1:

1 Like