My forum goes offline after removing https


(TheBurningMan) #1

One of my forum goes offline. I checked on sever but everything is working fine on server side.
Another forum is working fine but one goes offline.

Is anyone here facing this issue.

It will be great if anyone here will share how and when forum comes back online.

Thanks


(TheBurningMan) #3

Hey Discourse Team,
Kindly help me in this matter.
This is my forum link - https://forum.buzzbasement.com

I rebuild app two time still nothing happened.

What should I do for this.


(TheBurningMan) #4

I just found error in rebuilding but don’t know how to solve it.


(Bhanu Sharma) #5

What is occupying the port 80 on your server?


(TheBurningMan) #6

means, sorry I haven’t understand what you really want to ask


(cpradio) #7

Run this command, to identify what is taking up port 80 (and then provide us the output)
sudo lsof -t -i tcp:80 -s tcp:listen


(TheBurningMan) #8

3

What should I do right now


(cpradio) #9

Sorry, I copied and pasted it with an extra parameter, can you run it once more, using this (note: the missing -t argument)

sudo lsof -i tcp:80 -s tcp:listen


(TheBurningMan) #10

3


(cpradio) #11

Perfect, so you have apache2 installed which is taking over port 80. Are you running other sites on this server (other than Discourse)?


(TheBurningMan) #12

Nope, only this one.

I am using Digital Ocean.
I have one more Discourse but that is on another server and that is working fine.

Only this one is affecting


(cpradio) #13

okay, try running sudo apt-get remove apache2

If that doesn’t solve the issue, run dpkg -l | grep apache2 and remove each remaining component


(TheBurningMan) #14

I tried both but problem still exists


(TheBurningMan) #15


(cpradio) #16

Run the sudo lsof -i tcp:80 -s tcp:listen command again, is anything listening on port 80 anymore? From what I can tell, that is simply implying that apache2-bin apache2-data apache2-utils can be manually removed as well.

sudo apt-get remove apache2-bin apache2-data apache2-utils

The rc in front of apache2 means it was removed, but still has configuration files sitting on the system.


(TheBurningMan) #17

now,. nothing happens this time…
It is not listening on port 80 anymore


(cpradio) #18

If discourse was already installed, a reboot should be sufficient for starting it back up, or you can run

cd /var/discourse
./launcher rebuild app

(TheBurningMan) #19

Thanks, I will do that.


(TheBurningMan) #20

Hey @cpradio, I just rebuild but still same problem :disappointed_relieved:


(cpradio) #21

Anything taking up port 80 again? Are you sure it is the same error?