New topic and reply not working


#1

Hello, I’ve just put our forum live but the new topic button just doesn’t work most of the times.
When I click it nothing happens while everything else is still very responsive and it all works fast.
So I’m not sure what’s going on.

Is there an error log or something I can see somewhere?

Version v1.7.0.beta10 +42 1.7.0.beta10 You’re up to date!


#2

I get this error in the JS console

TypeError: Cannot read property 'id' of undefined
    at r.addUser (_plugin-third-party-3a7308e….js:51)
    at r.isOpened (_plugin-third-party-3a7308e….js:43)
    at Object.p [as applyStr] (_ember_jquery-37ec894….js:22587)
    at Object.d [as sendEvent] (_ember_jquery-37ec894….js:16115)
    at b (_ember_jquery-37ec894….js:19972)
    at Object.s [as propertyDidChange] (_ember_jquery-37ec894….js:19799)
    at Object.c [as set] (_ember_jquery-37ec894….js:20218)
    at r.set (_ember_jquery-37ec894….js:34525)
    at r.value [as _setModel] (_application-e4b1668….js:17649)
    at _application-e4b1668….js:17626

(Rafael dos Santos Silva) #3

Try disabling third party plugins on Safe Mode.


#4

Yeah that fixed it thanks.
Turns out it was the discourse presence plugin.


(Rafael dos Santos Silva) #5

So you need to remove the plugin from app.yml and rebuild.


#6

Yeah I have it’s working fine again now :smiley:


(Rafael dos Santos Silva) #7

Also, we had a PR that fixes the plugin, so now it works :sweat_smile:


#8

Ah alright nice :slight_smile:
I’ll try it again later.


(Jeff Atwood) #9