News Plugin 📰

How does a guy see this in action? is broken.

Also, do the images and text data roll off the forum after awhile? Otherwise, I could see this hitting harddrive space over time.

1 Like

Import Error: about.json does not exist, or is invalid. Are you sure this is a Discourse Theme?

i am encountering this error.

Because it’s not, it’s a plugin. You have to add this to app.yml and rebuild as per the link in the OP.


Great job. In fact, it replaces the blog. Is it possible to do something similar for embedded videos and channels for YouTube, etc.? For example, VideoBox - Video & Livestream Sharing Platform - Multimedia - Invision Community
This way we will get a universal all in one community platform with great capabilities. Before my thematic community, it is necessary to import channels with 200k+ videos with updates so that users can watch videos on the site, and not on third-party services. Embedded videos are liked by search engines and increase the time spent on the site hundreds of times.
Yes, the plugin is complicated, it should have navigation and a built-in video player, but it’s worth it. I think a lot of thematic communities will want to have such a plugin, and maybe all communities :sweat_smile: :grinning:
They tried to create something similar here, but it’s not the same at all (


I’m looking for the answer to this question too. When the site opens, I want it to open as


Just noticed that the Elektronauts site now supports embedded video (that is active/clickable) on the home page news feed. This is new to me, and something I’d very much like to see in the implementation I’m using. Is this feature implemented in the current version of the News Plugin?

Its been about 3 months since I updated my plugin.

I’ve tried many font awesome classes, (I’ve tried different formats), but the font/icon shows broken. This is the setting that I’ve chosen at the moment:

And this is what the front end shows:

Just reporting one small display problem. Rather than formatting the text visually, it shows so many html tags inside the news itself.

I don’t know if this the fault with the ‘rss feed’ or with the ‘news plugin’. Though I’ve checked/tested with 3-4 other (all Punjabi language) feeds, the same problem is with all of them.

For the icon, have you tried just the class name without the mark-up?

1 Like

I filled this <i class="icon-camera-retro"></i> and still the front-end shows broken icon.

And if I use only this icon-camera-retro, then the front end of the site shows no icon at all.

Who has this running on their forum so I can see an example?

1 Like

Hi. Thanks for the plugin. I’m trying to get it configured. I’ve got the variables set like this:

There is a /news route, but it just looks like a normal forum page:

What am I missing in order to make the page look like the example?

Does the lack of a green checkmark indicate that something is wrong? Is there something else I can check to see why the /news route only renders a normal topic page and the header doesn’t include the News link?

@Stanzilla Did you figure this one out? Was it a configuration problem, or a bug?

I just checked this plugin out on latest tests-passed and it appears to be working.

What is strange about your second screenshot is the lack of “News” link in the header - have you refreshed your browser since enabling the plugin?

Note that the Category Topic List should be unchanged: news works on its own route.

what happens when you navigate to /news?

Thanks @merefield Here’s a video of what I’m seeing.

Is there a log I should be checking for errors? Any other config params that are known to conflict (e.g. I’ve tried all the permutations of navigation, etc)

1 Like

That looks suspicious - what’s showing in the browser console?

The other place to check is /logs

app.js:29 Uncaught Error: Could not find module `discourse/components/modal/share-topic` imported from `discourse/plugins/discourse-news/discourse/initializers/news-initializer`
    at loader.js:247:1
    at c (loader.js:258:1)
    at s.findDeps (loader.js:168:1)
    at c (loader.js:262:1)
    at requireModule (loader.js:24:1)
    at e._prepareInitializer (app.js:23:1)
    at app.js:73:1
    at Array.forEach (<anonymous>)
    at e.start (app.js:66:1)
    at HTMLDocument.<anonymous> (start-app.js:5:7)
    at discourse-boot.js:18:12
    at discourse-boot.js:19:2
1 Like

Are you sure you have the latest code from tests-passed in Discourse and the latest version of the News plugin on main branch? There was a PR from @David 3 weeks ago that covered this off, which is why it is working on two dev instances for me.

Ah! I am on 3.0.5 in Discourse, because I didn’t know if 3.1.0-betaX was done/stable. I am using it with the News plugin main branch. Is there a version/branch of the News plugin that works with 3.0.5? If not, I will set about upgrading my Discourse. Thank you @merefield !