Non-http(s) urls in posts not hyperlinking properly


(Matthew Fay) #1

Hi guys,

On a newly-installed Discourse instance, I’m trying to hyperlink a Mumble server in a post body, which takes the form mumble://example.com.

I’ve tried with <a> tags and [markdown](links). Inspecting the post after it goes up, it looks like it’s not keeping the href in the <a> tag, as demonstrated in this example link which should lead to mumble://example.com.

I’m fairly new to running Discourse so I’m not sure if there’s a setting for security purposes perhaps that could be stripping the nonstandard protocol links? Possibly of note - the forum in question is running in a subfolder and seems to be fully functional, and the mumble:// link is to the same domain as the forum itself, as the Murmur server is on the same instance.

Any direction would be much appreciated, cheers.


(Matt Palmer) #2

Unrecognised URL schemes are not supported at present, however there’s a feature in the works to loosen these restrictions, so keep an eye out.


(Mark Alldritt) #3

We are trying to use the applescript URL scheme for code blocks in our Discourse forum and a solution for this issue would be very helpful.


(Matthew Fay) #4

Thanks for the heads up. Is there a PR or something I could follow?


(Matt Palmer) #5

That would be provided in the post above yours.

No, it’s just part of the intended featureset for 1.7, as described in #releases specifically, “Support alternate URL schemas if allowed such as ftp://, steam:// etc”.


(Neil Lalonde) #6

Support for more url schemes has been added! There’s a new setting called “allowed href schemes” where you can add a list of schemes to allow in links.


(Rafael dos Santos Silva) #7

Testing:

Hey guys add me on Steam to play some Dota 2 :video_game:

EDIT: It works!

For better use:

  • steam://friends/add/76561197988628148 for adding someone

  • steam://store/570 for a game page


(Joshua Rosenfeld) #8

Umm…nope. First link went to user search page. Second link went to store main page.


(Neil Lalonde) #9

Both work for me. Which browser/OS are you on?


(Joshua Rosenfeld) #10

Me? Chrome 53, Windows 10 Pro.

Both links popped up this dialog where I clicked Launch Application:


(Rafael dos Santos Silva) #11

@jomaxro I had wrong links, try now!


(Joshua Rosenfeld) #12

Add friend isn’t opening Steam at all now, Dota 2 link is working.


(Rafael dos Santos Silva) #13

Did you add me manually?


(Joshua Rosenfeld) #14

Not that I’m aware of! I was never given an option to friend you…that’s wierd.


(Rafael dos Santos Silva) #15

I used a too agressive option :stuck_out_tongue_winking_eye:

So it works, and now we are friends for life.


(Neil Lalonde) #16

As long as the external protocol request happens for the given url, then it’s working. And making new friends is pretty cool too. :green_heart:


(Jeff Atwood) #17

@neil the raw version should work too…

steam://store/570


(Neil Lalonde) #18

Yeah, I forgot about that case. Will handle it next.


(Neil Lalonde) #19

We decided not to handle that case (raw text) since it’s tricky to get site settings into an engine like auto-link.


(Rafael dos Santos Silva) #20

Maybe we can postpone until commonmark move?

http://spec.commonmark.org/0.25/#autolink