Not Able To Send Mail - Access Denied


I’m trying to set up mail with MailJet. The domain name and email is approved on my MailJet dashboard, but I can’t receive mail to access my admin account. In the guide it says to check the logs at /var/discourse/shared/standalone/log/rails/production.log. When I insert that into the console, it says access denied. I’ve checked an the email is set up properly.

1 Like

/var/discourse/shared/standalone/log/rails/production.log is a file path, you may view it by connecting to your server over ssh. You may need to use sudo to view the file, adjust to however you are viewing it.


So all together, how should that look written in the console?

I’m not sure what that means, so I’m not qualified to explain. I normally ssh into the VPS and use something like less to read files.

Also, Search results for 'production.log' - Discourse Meta.

Good luck! :slight_smile:


Thank You, that helped.

But I’m still not able to set up the mail to work

1 Like

Typing “MailJet” in the search will give you quite a few topics regarding setting up MailJet.
To access your admin account, use this https://YourForumDomain/admin
If it prompts you to login in, just use the email address you used to set it up (and the password).

1 Like

I get brought to a page that says it doesn’t exist. I searched the forum but I can’t find any useful info.

The main problem is that MailJet is not sending a verification email so I can log into my admin account.

1 Like

Can you see your site from the Internet by type your forum’s URL in the address bar? It would help to give a little more information about your site. Where is it hosted (Digital Ocean or another cloud service, or a dedicated server?).

1 Like

The issue is that the admin email won’t validate to get past the wizard.

The cause is likely mailjet settings or something blocking comms to mailjet from the VPS.


Yes I can

Domain from NameCheap, hosted with Digital Ocean, and MailJet for mail.

Would you happen to know a fix for this?

Ok, it looks like the email problem got self solved. I got an activation like in my email, but when I click it, this comes up:


That email was sent to me while I was sleeping so by the time I clicked the link it was 10 hours old, did it expire?

Yes, it expired. Were you able to get it working on your Digital Ocean server?

1 Like

No, it still doesn’t work

:frowning_face: I’m sorry to hear that. Are you following the steps on Set up Discourse in the cloud in under 30 minutes to install it?

Sorry I thought you were talking about something else

My Discourse forum is up and running

1 Like

Perfect! :smiley: I’m glad you got it working! Take care!