Notification of a flag is shown but no active flag present

notifications

(4ndY) #1

I have the same situation described as here, except that I have administration account, and the newest version of Discourse, so I should definitely see flagged PM. The flag notification is there, but there is no active flag listed.

I tried to rebuild Discoure’s container but it didn’t help. Is there any way to easily trace back where the “count” of flags is created?


(cpradio) #2

Did you have Post Moderation Queue enabled at one point? Try re-enabling it and seeing if any posts are in the queue.


(4ndY) #3

Hi @cpradio, what is the official name of this option (I cannot find it inside Settings)?


(cpradio) #4

Okay, so I’m not 100% sure either… as I’ve only heard it being suggested as a possible issue from others, but maybe it deals with these two settings?

Do you have the Akismet Plugin installed?


(4ndY) #5

Thank you @cpradio I’ve fixed it thanks to your advice.

I’ve changed “approve post count” to some number. After that “Needs Approval” showed in “hamburger” menu where I found one post pending. I think that this behaviour should be considered as a bug and solution would be to add an additional check for showing this “Needs Approval” item in the menu, something like this in pseudocode:

if settings.approve_post_count == 0 and pending_posts == 0:
     menu.needs_approval.hide()

(cpradio) #6

This has come up enough times that I don’t disagree with you. :smile:


(Robin Ward) #7

I agree this has come up enough times that we have to do something about it:

https://github.com/discourse/discourse/commit/e52ed6606977fb10d88e9581260fe3f4727de972

If any posts need approval the link will show up, even if the feature is disabled.


(Robin Ward) #8

(Régis Hanol) #9

Complaints Driven Development :tm: