Outbound notification e-mails failing after attempt to change attachment size limit

Outbound notifications upon new postings were working just fine. I tried to increase the email total attachment size limit kb to 25 MB which then produced the attached error (image 1)

I then tried to unwind the change and set email total attachment size limit kb to 0 in order to disable outbound attachments, but that just changed the value displayed in the error to ‘0’ and the error persists. (image 2)

Error Message: undefined method “kilobytes” for “25600”:String.

Maybe try updating your site. It seems that the issue was recently fixed: Error message when uploading logo.


Hi Simon,

Thank you for the reply! I just installed yesterday , so I believe I’m currently running the latest version.


After my install, I was doing quite a bit of testing and outbound notifications were working great. It wasn’t until I changed the size limit for attachments that the problem cropped up. Since then I’ve tried setting it back to zero as I mentioned. I have also restarted the server. Any other thoughts? I have not tried a rebuild but that might be next.

Hello and welcome @managenet :slight_smile:

Could you try updating from your /upgrade page? It may be easier than a rebuild. This should pull in any fixes that were created yesterday and will tell us if there’s another edge case that’s not been caught with this issue.

1 Like

Oh you guys are good!

I updated from the /upgrade page as suggested, and … like magic, the upgrade ran efficiently to completion and all was put to right.

With the ‘email total attachment size limit kb’ value still set to 0, I verified successful outbound notifications (including those that had been in the queue)

I then set the ‘email total attachment size limit kb’ value to 10 MB and verified successful outbound notifications include attachments as expected.

This bug appears squashed.

Thank you very much for all your hard work on Discourse and for the prompt replies! It is very much appreciated.

1 Like

This topic was automatically closed after 3 days. New replies are no longer allowed.