Plugin page not loading unless I hard refresh (Chrome)

When opening /admin/plugins the plugin list/settings do not show. Only after a hard refresh, the plugin page loads correctly.

Build: 2.9.0.beta10 - (7718ef97cc)

I’ve seen something similar happening with the adplugin + an adblocker. Is this one of those situations?

If you do have the adplugin, does the same happen in an incognito browser?

1 Like

Not seeing it on Firefox and Chrome.


We’re 1 commit behind but it shouldn’t make a difference.

I had an Adblocker on both.

Behavior is the same in incognito, also had adblocker whitelisted for my own domains anyway but was worth a shot. Does not happen on mobile btw, just desktop.

Checking the console:

Uncaught Error: There is no route named adminPlugins.houseAds

When I refresh, the console error pops up after loading the page for a while, but no settings will be loaded. On hard refresh the page loads fine. After a hard refresh, a normal refresh will result in not being able to load the page again.

1 Like

This does sound like the adplugin + adblocker issue. Is there some way you can test this in a clean browser with no adblocker?

I disabled the plugin and it works perfectly now… strange that even whitelisting (aka disabling adblocker for a domain) did not help.

After enabling the adblocker again, it still works as expected… will see how it goes.

1 Like

I was going to suggest disabling, but I saw you’d already tried safe mode and thought you’d need to uninstall it (which seemed a touch too far this early in the debugging :slight_smile:). It’s good to know that disabling is useful for fault-finding. :+1:

I am unsure why whitelisting hasn’t worked, as that’s another tip we’d offer as a workaround. :thinking:

1 Like

I ruled out adblocker because of the safemode where it still didn’t work indeed. Maybe it was a bug in the adblocker :confused:

But on another note I just did a test to see what I should see when safe mode is enabled now that the issue is solved, /plugins/ does not load in safe mode at all, even with adblocker disabled :laughing: - so giving the exact same result as my screenshot above. Refreshing to exit safe mode works and plugins load instantly.

1 Like

Ha. :slight_smile: Yes, that does make a lot of sense. I’ve clearly not had enough cups of tea this morning. :slight_smile:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.