Polls, Spoiler, Details, Calendar, etc menu options missing

Hello all,

As mentioned in topic title, all the extra Discourse menu items in the composer window are missing after updating to 3.1.0.beta5 (tests-passed) yesterday. Oddly enough, other items like “Toggle Whisper” and “Canned Replies” are still there.

What should look like this (screenshot from Meta):

Looks like this:

I’ve spent an hour trying to track down the issue in our install with no success, so I’m hoping someone may be able to point me in the right direction.

For the sake of thoroughness:

  • I’ve rebuilt the app from the command line
  • I’ve tried safe mode
  • I’ve switched themes
  • I’ve toggled the items that are not extra plugins on and off
  • I’ve reviewed the logs (no related errors)
  • I’ve reviewed the console window (no related errors)
  • I’ve switched browsers and checked both desktop and mobile
  • I have not reinstalled plugins yet, since some of these menu items are integrated into core

Trying to use the [spoiler] or [details] codes manually does not work anymore. Any old posts using the Calendar function are baked into the post now, rather than updating dynamically. Polls have the same issue and no longer function correctly.

I’m completely stumped now. If anyone has any suggestions or recommendations, I could really use the help. Site is at https://forum.wackywriters.com

I don’t want to consider this a bug until I’m sure I’ve exhausted all other possibilities.

1 Like

If I disable Unofficial plugins in safe mode the options appear back in the menu again:

Do you have any that could be likely culprits?

I’m sure it’s likely, but I did the same thing (disabled unofficial plugins) and had the same issue. I did it a few times, actually. But you being able to see the options tells me there’s probably something client side on my end messing with things. Thanks for checking for me, at least I know it’s something I can eventually track down and fix.

1 Like

Aha! Custom Wizards plugin. I don’t know why disabling them in safe mode didn’t fix it for me (I swear I did so numerous times), but I went through the unofficial ones and thst one was the culprit. :woman_shrugging:t3: thank you again!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.