Post won't save (text included)


(Clay Heaton) #1

I’ve tried 10 times to save the post, the body of which is included in the attached file here:

problem_post.txt (2.5 KB)

Discourse just hangs on “Saving…” and never does anything. I have tried writing other posts and they work just fine. I ran ./launcher rebuild app and still experience the same problem. There are no errors (that I see) in the logs.

Ideas?


Indication of whether a post actually has saved
(Zack Piper) #2

Very weird, mind giving us the Discourse version?

And, when trying to save a post, could you give us a screenshot of the developer tools? (F12 in almost all browsers)


(Clay Heaton) #3

Version is v1.4.0.beta9 +247

Here’s the screenshot.

The save request eventually times out and an error pops up.


(Zack Piper) #4

Okay, hmm.

Is this on a subdomain, or on a normal path, and can other users post?


(Clay Heaton) #5

An internal subdomain at my company. We have ~ 160 active users. There don’t seem to be any other problems posting. It’s specific to this post.


(Zack Piper) #6

Alright, I guess you can post things other than this post.

I’m thinking if it has something to do with the category you’re posting in, is it new at all?


(Clay Heaton) #7

Nope… it’s been around for 6 months and has a lot of posts in it. For what it’s worth, it will post neither as the first post in a new topic nor as a reply to an existing topic, regardless of category.


(Zack Piper) #8

Okay, one moment, let me try posting it on my discourse as a test.


(Clay Heaton) #9

For what it’s worth, it sort of reminds me of this weird bug. Maybe it’s finally a repro case of it? Who knows…


(Kane York) #11

Two people (including me) have posted it on try.discourse.org successfully. A full browser refresh (Ctrl-Shift-R doesn’t help?)


(Jeff Atwood) #12

I suspect you have some kind of client “antivirus” that is ham-handedly detecting this as an exploit and interrupting the HTTP connection. Have seen it before!

(Assuming as @riking said him and another have been able to post it on try.discourse.org just fine)


(Clay Heaton) #13

Well, I’m on a fresh install of the latest version of OS X and I can reproduce it in Safari, Chrome, and Firefox…

I was trying through a VPN connection, which could be part of the issue, but like I said, I can make other posts successfully - just not that one.

I’ll try to narrow it down to the smallest piece of text causing the problem and I’ll talk to IT about whether there’s some filter on traffic.


(Clay Heaton) #14

So this is weird… I did additional testing.

I can post the entire post successfully EXCEPT when I include the first two lines in the text document at the top. If the first two lines are included, then it fails to post. If I try to post just the first line, removing the period and everything after it, then I can post. So it has something to do with the period, carriage return on the first line, or space/carriage return on the second line. If I start with the “1. Press…” from line 3 and grab the rest of the text, it posts without a problem.

Here’s the editor, stuck in “Saving…” before trying to submit the post.


(Mittineague) #15

Might a BOM be involved?


(Clay Heaton) #16

I’m not sure? I typed the post in the Discourse edit window; nothing fancy. It seems like the failure is happening client-side. What’s the best way to see what Ember is up to when I click to post or when it’s trying and failing to save the post mid-edit?


(Jeff Atwood) #17

Can you repro this on try.discourse.org ? That was not covered in your two posts above, and is critical information.


(Clay Heaton) #18

I cannot repro it there. :sadpanda: However, posting it there does reveal another bug, which I’ll post in a different topic.

I’ve rebuilt the app again, cleared caches, done hard browser resets, and it the post still will not post to the Discourse I manage. Oh, well… I’ll just change the text. If you have any other thoughts about debugging, I’m happy to do them to see what’s going on.


(Jeff Atwood) #19

Unless you have unusual plugins, I am 100% certain there is something on your network intercepting and blocking the request.


(Clay Heaton) #20

Perhaps. Weird that it’s restricted to whatever is in the first two lines of that text. I’ll keep looking at it to try to figure out what’s happening and I’ll see what happens when I’m not on the VPN tomorrow.


(Jeff Atwood) #21