Problem linking Discourse forum to WP Discourse

Hi folks. I too, am having issues connecting Wordpress (5.7.1) to Discourse (2.7.0.beta7).

I’ve installed the WP_Discourse plugin on another Wordpress site to hook into my Discourse forum. For some reason it refuses to connect even though the API is correct and set to all users as well as the admin username properly set.

The plugin does pull in the name and URL of the forum in other parts of it but it still says: " **You are not connected to Discourse. If you are setting up the plugin, this notice should go away after completing the form on this page.*"

I also noticed since upgrading to the latest version of Discourse (I was a couple versions behind), on another WP site the plugin is no longer connected and when I try to reconnect it has the same issues above and is no longer connected.

I deactivated all WP plugins except for Discourse to see if it solved the issue, no go. Also checked security settings in Discourse to make sure I hadn’t inadvertently blocked all crawlers, etc. Not the issue.

I reissued Global APIs just in case. Natch. I also set up a global API just for my admin username and used that key, still natch.

Changed from my username to system as username, still no go.

Not sure what else I can do – how can I debug this further? Also, could it be a firewall issue? What ports are used?

Thanks,
Ray

P.S. I did recently change domains on the Discourse instance and followed the directions here. Everything else seems to be working fine.

Only other change is I recently updated Discourse from a couple versions behind to the latest.

UPDATE: On a hunch I rolled back the updated Discourse back to 2.7.0.beta3 and both of my Wordpress sites are able to connect to Discourse so I’m guessing there’s something in the updated versions of Discourse after 2.7.0.beta3 that might be causing issues?

UPDATE 2: I believe the issue has to do with changing domain names - I was finally able to update Discourse to the latest version and Wordpress was able to hook into it. However, each time I change the domain over, it fails. I’ll have to dig into it some more - I bet it has to do with a stray domain setting somewhere despite following the directions here to the letter.

UPDATE 3: Dug into the logs, I see I exceeded the rate limit for Let’s Encrypt so I’ll have to try again next week : /

Let me know how I can help debug this.

Ray

P.S. I tried to change the domain and do a rebuild without updating Discourse per this but for some reason the rebuild updates to the latest version so I’m unable to debug this further.

1 Like

Hey @Solari, sorry for the slow reply here I missed this somehow. I’ll respond in detail on Monday.

1 Like

No worries. I’m positive my issues are with exceeding the rate limit for SSL cert requests while testing the thing out. ; )

1 Like

Just to clarify, the WP Discourse Plugin has no issues with the latest Discourse. You can see the plugin working with a Discourse instance that is automatically updated to the latest Discourse version every 24 hours here: Wordpress - Try Pavilion. The Discourse it is connected to is here: wordpress.thepavilion.io

Apologies if you mentioned this, but just checking you’re also updating the Discourse URL in the WP Discourse plugin’s connection settings?

1 Like