ProCourse Installer - Installing/removing plugins via the UI

It would seem that those days are gone.

That would be the first thing to try. Have you not tried that? You’d remove either all of them, and then add them back until you see the problem, or one-by-one remove ones that you think might be causing the problem.

ProCourse Installer - Installing/removing plugins via the UI describes how to delete them if you can’t get to the admin panel.


@pfaffman @Falco Uninstalled ProCourse, as well as all other unofficial and official plugins. After rebuilding the app, still same thing. Notifications won’t login and Notifications tab appears empty for some users even if they keep receiving them.


I really don’t know what else we can do. It was clearly not coming from the plugins, but we had to try. What else could we do?

Yes. You had to try. Removing plugins is always the first step with almost any problem.

Next guess would be themes. Then ram and disk space, which also seem unlikely. Do you have swap?

1 Like

@pfaffman I’ve started a new topic since it’s not a plugin issue. I’ve mentioned everything I’ve done so far.


Hi, i tried installing a plugin but it gave a unicorn stopped unexpectly error and the plugin tab now looks like this. This is happened before to me with other plugins when installing them. Is there a way to fix this without rolling back to a backup?

@Noba Have you fixed this issue yet? I just lost all my plugins installed through ProCourse installer.

Your best and most reliable bet will be to install them in your app.yml file.

@pfaffman Yes, however our site goes down for 5-6 minutes while rebuilding and we don’t wanna do that every time we add or remove a plugin, since people start complaining. That’s the only reason why we’re using it.

We had an issue with one of the plugins, which completely broke the site, so I completely removed ProCourse Installer it from app.yml, but seems like there are still some plugins installed through ProCourse, which won’t appear in app.yml. All that made our site 4 times slower now. Any idea how to remove them?

Then you should switch to a 2-container install (How to move from standalone container to separate web and data containers). That reduces downtime to about a minute.


If you removed the installer plugin and did a full rebuild, those plugins will be gone as there is no active mechanism to install them on rebuild.


No, I didn’t, I just ended up reloading a backup before the glitch. Though I haven’t had it reoccur since I added more space to the server so I don’t know if that has any correlation or not.

Hi Joe!

Awesome plugin! Makes life much easier.

I have encountered a problem. While installing Retort plugin it seems to have stalled during install

And Stuck on Spinning up Below

It has been stuck at this point now for and hour or more. How do I go about fixing this? Can I logon to server and edit app.yml remove Retort Plugin save and rebuild?

Thanks again!


Found it was Docker Manager upgrade that hung it up. Reset Docker Manager Upgrade and initiated Docker Manager Upgrade.

Waiting for it to complete before installing more plugins.



For some reasons, I can’t access the Plugins section anymore:


Any idea why?
Is Discourse.Route has been removed and the plugin needs to be updated?

EDIT: Looks like it was that. Made a PR on the repo:


I moving to new server. Just lost all plug-in install will procourse-installer. They still display in admin/plugins/procourse-installer/installed but actually do not exist.

1 Like

Have you rebuilt since you restored the database?

EDIT: It sounds like rebuilding might be source of the problem!

Last time I used procourse installer, it properly installed plugins, but these plugins were removed upon rebuilding.

A friend had issues with it too. If issues happen to other people and the plugin isn’t maintained anymore, maybe it should be moved in #plugin:broken-plugin. :man_shrugging:

1 Like

I already rebuilt many time

Given the plugin current state, you should remove it and go back to the regular way to install plugins by editing app.yml.

1 Like

Yea, i already do that. Great thing is all plug-in setting is still in database so no need to setting again.

1 Like

Moved to #plugin:broken-plugin for the time being. If it’s fixed at some point let us know and we’ll move it back.