Published page not visible?


I was playing around with the Page Publishing feature and noticed that pages that are also “docs” (Discourse Docs (Documentation Management)) do not appear as published pages.

That is to say, I can publish them and the page is generated but the page appears as a blank screen. The content appears to be there when I use the browser inspector but is just not visible.

I experimented with topics that are “docs” and they all have this problem (even when I removed their “doc” tags!) and topics that weren’t “docs” did not have this issue.

I attempted to navigate to the published page in safe mode but it didn’t seem to make a difference.

Just wonding if this is only a problem on my end (some weird plugin combination?) or if others are having this issue.

Hi scottmastro,

I tried to recreate this on my site also running 2.9.0.beta7, but was unable to reproduce this behavior.

What browser were you viewing your site with? It’s interesting that the content was present when you inspected the page, but was not actually displaying anything. For my testing I was using Chrome Version 103.0.5060.134 and Firefox 91.12.0esr.

Do you recall generally what kind of content was in the Doc topic you make into a published page? I’m wondering if there might be content from another plugin in the post that could be causing this issue besides the Doc plugin, or if the content was just using core Discourse features (plus the Docs plugin).

If you create a topic with the exact same content as the one that’s showing the blank published page, but never include the tags to make it into a Doc, is the issue still present? It’s odd that the issue with the publish page topic persisted after removing the Docs tag.

Hi, sorry for the delay I’ve been pretty busy this past week.

It very much could be another plugin causing the issue but the only consistent pattern I found was that they were all docs.

Here is an example of a published page with this issue (let me know if you see the same problem on your end):

Here is the original topic:

See below, it appears to work

I also tried on a separate theme that has less components and the issue persists.