Quick Messages Plugin


(Angus McLeod) #204

Thanks. I did find a bug and fix it. But I’m not sure if it was your bug…

https://github.com/angusmcleod/discourse-quick-messages/commit/240d78688f9882c998e26073802b3aae71e67d56


(Aman Jagga) #205

@angus . It’s again not working with latest discourse version 1.8.0.beta1. Neither I could see anything in error logs nor in chrome developer tools. please check

Also, can you tell me how to disable this plugin for now. I couldn’t find any setting to disable this plugin


(Anton) #206

To exclude the plugin from execution altogether, just remove it from your app.yml file, same was as you included it when installing the plugin. then rebuild Discourse again.


(Aman Jagga) #207

I think that’s only the workaround, a plugin should have the switch to disable through admin dashboard,I am wondering why a switch is missed in such a popular plugin.


(Angus McLeod) #208

I’ve updated this plugin so that it works with the latest Discourse and added a setting that lets you disable the plugin.


(Aman Jagga) #209

Thanks @angus for the quick fix and incorporating the feedback to provide a setting that lets you disable the plugin.


(Aman Jagga) #210

I found two minor bugs in the new update -

  1. If you open a chat window, closes it and then re-open the same chat window, I am not able to open
  2. Chat window position is not fixed at the right side, when we open a chat window then closes it and then opening a another chat window.Attaching screenshot for the same.

I think these bugs are related to each other only


(Asif Eminov) #211

I opened

nano app.yml

opened this file and add this code

hooks:
  after_code:
    - exec:
        cd: $home/plugins
        cmd:
          - mkdir -p plugins
          - git clone https://github.com/angusmcleod/discourse-quick-messages.git

after saved file, I rebuild docker via

cd /var/discourse
./launcher rebuild app

But I can’t see this plugin in plugin area, and in my messenger. Why?


(DiscourseMetrics.com) #212

Great Plugin!

When I minimize a chat it seems to disappear completely :slight_smile:


(Matt Landseadel) #213

First - GREAT plugin. Love it. My users love it. Great. Thank you!

I’m running into a little issue. I get that the Hide/Close buttons close the direct message box. BUT if I click on the X to close the message box, the New message box will no longer display.

After closing a message box, later when I try to click on the envelope icon, then New Message button, the direct message box will not return.

The new message box will return most of the time if I had clicked on the down arrow to hide the message box previously. I can also click on a previous conversation and the message box returns.

If I refresh the browser window, it fixes the issue…


(Angus McLeod) #214

Hey guy’s, I’m just getting back on board with Discourse work after going away over Christmas / New Years. Some initial responses:

@Aman_Jagga That looks like a bug, I’ll address it asap; probably tomorrow.

@eminov You need to enable the plugin now. It’s off by default. See quick message enabled in Settings > Plugins

@DiscourseMetrics.com That is default Discourse behavior. If there is no draft content in the compose, minimizing the compose will make it disappear entirely. However considering you’re the 3rd person to comment on this, it seems people do not expect this from a ‘chat’ compose as opposed to the normal Discourse compose. I’ll have a think about changing that behavior.

@HemophiliaFed Looks like you are describing a combination of the issue @DiscourseMetrics.com was describing and a straight up bug. For the part about minimizing the compose, I’ll consider this as mentioned above. For the ‘bug’, i.e. the compose no longer appearing, I’ll take a look at this asap.


(DiscourseMetrics.com) #215

I was expecting minimizing to attach the chat-window to the bottom of the screen but make it smaller than normal (hiding the chat content and just showing the name of the person I’m chatting with). I guess I’m used to other chat-systems that do it this way :slight_smile:


(Angus McLeod) #216

Just pushed a bugfix which is probably the culprit for the reported bugs and an update to the minimize behavior so that the composer will minimize (rather than close) even if there is no draft text.

You can see the updated Quick Messages in action on my new dev instance: https://dev.civll.com/


(Asif Eminov) #217

@angus I don’t see this plugin in settings > plugins area


(Angus McLeod) #218

@eminov If the plugin is enabled, you’ll see three settings in Admin > Settings > Plugins.

You can tell whether the plugin is enabled by whether it appears as Enabled in Admin > Plugins.


(Asif Eminov) #219

I don’t see this plugin settings on plugin area.


(Mittineague) #220

The plugin.rb file needs a

# url: http://someurl/typicallygithub.git

for it to show there.


(Asif Eminov) #221

Look this: Quick Messages Plugin


(Matt Landseadel) #222

@angus Thanks for the updates! Looks like they’re working great.


(Ruxan) #223

thanks for this plugin, its sexy as hell :slight_smile: