[quote=reply issues] without adding additional text

Hey there,

I have used the search but couldn’t find this problem/bug.

When just replying with

it gives you the error that you are not allowed to reply with an empty post.

However, if you reply with

if works just fine.

What is the reason for that?

There are many many ways to work around post length restriction, we try to catch the trivial ones, but some more exotic methods of circumventing post length check sneak through.

5 Likes

just so I understand it correctly, the intention is that you should be able to respond with a quote or that you should not be able to respond with a quote?

I would like it to be the first option :slight_smile:

Oh I think you are talking about the site setting: remove full quote, it is enabled by default. You can disable on your instance if you prefer.

You can also adjust min post length if you prefer shorter posts.

2 Likes

no, I guess neither of the two.

It seems to be an issue with adding an author to a quote and just replying with that quote and nothing else. You can try it here.

I hope that I could make it easier to understand.

@sam is there a fix for that (in planning)?

A post that only contains a quote from another post and nothing else doesn’t add much to the conversation. Post quotes are stripped out when calculating the post length. So, the post length is effectively 0 if that’s all the post contains. That’s why you see that error. It’s been that way for a long time.

Quoting another reply won't satisfy the minimum character count (fixes #180) by ZogStriP · Pull Request #304 · discourse/discourse · GitHub

When you quote a post in Discourse, you get this in the composer.

[quote="user, post:1, topic:558"]
some quote...
[/quote]

All of those characters are not counted.

See here

discourse/quote.js at 1472e47aae5bfdfb6fd9abfe89beb186c751f514 · discourse/discourse · GitHub

and here

discourse/composer.js at 91a816e788cc59395dba9a74c96e2e632d8caf15 · discourse/discourse · GitHub

This is very different from a generic quote like this

> Most people do not need more space, they need less stuff. ― Michelle Ogundehin

which renders

Most people do not need more space, they need less stuff. ― Michelle Ogundehin

since I’m presumably adding to the conversation rather than reposting something from another post without adding to it.

2 Likes

thank you for your reply and the additional information on the topic. However, I’m not talking about quoting someone else on the forum I’m just refering to the [quote] functionality.

Sometimes I read something on another site and just want to quickly quote from there and giving that quote a source (=author). E.g. something another person said.

So it is new content, but from someone/somewhere else. I get that a direct quote in the forum does not count as post length.

Nevertheless, just quoting works, but quoting with adding a “source” does not work anymore. This just seems weird to me.

I understand what you’re saying.

this works as a reply without any other text

[quote] some text... [/quote]

this doesn’t

[quote=me] some text... [/quote]

The reason is still the same as I mentioned above. When you add the = character, it matches internal Discourse quotes. So, the assumption is that it’s a quote from another post, and it gets stripped.

You can do something like this if you want to add an external quote.

> me:
>
> Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do  tempor incididunt ut labore et dolore manga

renders like so

me:

Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do tempor incididunt ut labore et dolore manga

Short of that, you’ll need to look into adding custom functionality to your site.

A change in how Discourse handles this in core is unlikely given that this hasn’t come up before. The benefit of stripping internal quotes far outways the use case of allowing posts that only contain an external quote where you manually add the source.

1 Like

ok, now I understand it. Thanks for the clarification and for your help!

Maybe you could make it an option in the settings :slight_smile:

2 Likes