Quoting not working

One pattern I noticed recently is that it doesn’t work on closed topics (on the Discourse Hub app at least). I’d rather it were possible but can see the logic of the current approach.

1 Like

How can you quote somebody in a topic where you aren’t allowed to post?

Regardless, that is unrelated to the topic at hand.


You can’t. I noticed that when part of a reply in closed topic A was directly relevant as an answer to a question in topic B.


1 Like

You can’t - but you can share. The same issue arises with Share on my Discourse instance.

1 Like

I’m also on 2.6.0.beta5 and quoting works fine with light and dark themes. I’ve tried it with:

Word code code word word

Linked with the “topic in which you are not allowed to post” point from earlier, could your problem be linked somehow to whatever trust levels you have set up on your site?

Do you just mean share a link? That’s what I did in the end.

1 Like

Looks a lot like this topic:

The issue had appeared for some when updating to 2.6.0.beta2, others to beta3.

After updating to beta4 and rebuilding the app, the issue disappeared, and didn’t reappear after updating to beta5. So perhaps try updating to beta6 and see, otherwise wait for further updates, it may get solved at some point.

Have seen the same issue, on Meta as well, doesn’t seem logical to me.


Have the composer open before you navigate to the closed topic, and the quote button should show up again.


Don’t we have to report this as a defect? How else can it just get solved? The general thread here seems to be that if we cant duplicate it on this Discourse site then it’s not a bug.

I am using beta6, and I have done a complete rebuild as requested. Issue persists.

1 Like

Unfortunately, we can’t fix what we can’t reproduce… if you can provide reproduction steps here on meta or try, that’d be a start.

1 Like

This is philosophically somewhat of a conundrum. Several people at least including me have the issue, but nobody knows how to make it happen on Discourse Meta posts. The issue clearly exists and can be demonstrated, just not here. I am not sure what to do. I am on beta6, docker image rebuilt, platform Ubuntu 20.04, all OS updates applied. Issue arises in any browser.

Would it help to have a login to my site?

The fact that we cannot demonstrate it here, yet it is a real phenomenon, that is telling us something in terms of debugging, but I don’t know what. But it’s some sort of clue.

1 Like

Yes, it likely indicates that you have a customization, plugin, or site setting that is somehow causing the behavior.

You can also attempt duplicating the quoting problem on try.discourse.org as well, which is an even more minimalist Discourse installation.


We’ve linked to sites where this can be reproduced.

Is this site running vanilla Discourse, with no customizations or plugins? (How come then the quote button on this site looks different than on every other Discourse site I’ve used? This site also has a confusing “Share” button when you highlight, which seems unique.)

1 Like

FWIW, these are our plugins:

Installed Plugins

Name Version Enabled?
discourse-solved 0.1 Y Settings
docker_manager 0.1 Y
retort 1.2.3 Y Settings
styleguide 0.2 N Settings

Anything sus here?

1 Like

That’s my guess. It’s a non-standard plugin.


Confirmed that quoting still does not work, even without that plugin. Our installation is now vanilla Discourse and quoting is not functional across tag boundaries.

You rebuilt your site without that plugin? Safe-mode is often not enough to remove a plugin.

I disabled the plugin. Discourse is giving me errors when I try to rebuild or upgrade.

Are you not able to reproduce it by clicking the link to one of our sites and highlighting some text?

that’s not the same as removing it.

Even if you remove the retort plugin?

It doesn’t matter. You say that they have retort installed.

1 Like

Perhaps you could be helpful then and tell me how to rebuild the site?

@Andro Do you have the retort plugin installed?

I’m sorry I don’t seem helpful. It’s generally assumed that if you installed a plugin that you know how to remove it. If you were one of my clients I could do it for you. If you would like for me to do it for you you can subscribe to this service. EDIT: Your problem appears to be beyond the scope of that service. Best of luck to you!

Edit app.yml. Remove the line that includes the retort plugin.

./launcher rebuild app

See Install Plugins in Discourse for more instructions.

1 Like