Quoting not working

I’m sorry I don’t seem helpful. It’s generally assumed that if you installed a plugin that you know how to remove it. If you were one of my clients I could do it for you. If you would like for me to do it for you you can subscribe to this service. EDIT: Your problem appears to be beyond the scope of that service. Best of luck to you!

Edit app.yml. Remove the line that includes the retort plugin.

./launcher rebuild app

See Install Plugins in Discourse for more instructions.

1 Like

You can also try to repro at try.discourse.org – you might also try reproducing in a web browser you don’t normally use, to rule out any unusual local browser customizations or plugins.

We were never able to reproduce this the last time it was reported; I don’t expect this time to be any different. Can’t fix what we can’t reproduce, unfortunately.

2 Likes

Did you go to the (multiple!) sites where it is happening and actually try? All you have to do is select text. Because we have about a dozen people across multiple sites reporting the problem.

It just says:

WARNING: Docker version 17.05.0-ce deprecated, recommend upgrade to 17.06.2 or newer.
You have less than 5GB of free space on the disk where /var/lib/docker is located. You will need more space to continue
Filesystem      Size  Used Avail Use% Mounted on
/dev/vda1        50G   42G  5.0G  90% /

Would you like to attempt to recover space by cleaning docker images and containers in the system?(y/N)y
If the cleanup was successful, you may try again now

But it doesn’t do anything different, no matter how many times I run it.

It’s generally assumed that installing a plugin without editing a yml file would imply being able to remove it without editing a yml file.

Unfortunately we are completely powerless to fix a problem we can’t reproduce.

1 Like

What about getting a new Digital Ocean droplet (or similar) and installing Discourse from scratch? Then restore your data into it and try again? There are recent topics about that. Then reinstall that plugin. If it starts working then you’ll likely never know what was wrong to begin with but you won’t care any more :slight_smile:

2 Likes

Absolutely

There is no way to install a plug-in without editing a YAML file

2 Likes

I can imagine the requirement to fix a Discourse bug is not reproducing it on any given Discourse site, but on a site over which the Discourse team has control to reproduce themselves, get logs, modify settings, test, etc… Otherwise how do you expect them to fix it?

1 Like

I’m not sure whether to laugh or cry. Today on my site the quoting works fine. Yesterday, despite previously having first a while ago not worked in any browser, it worked in Edge and Opera but not Chrome or Firefox. Now unexpectedly working as expected in all.

I have never had any plugins apart from what Discourse comes with. I am on 2.6.9.beta6, updated to the minute with the latest commits. Running on Ubuntu 20.04 LTS on DigitalOcean droplet.

So this is great. But mystifyuing. Obviously sofware cant fix itself, so there must be some tiny chnage in OS, browser, or Discourse that is influencing this, but may never be able to be identified. The only thing I can say is that I have ‘graceful’ theme installed, and it has underdone some turbulence in terms of quite a few updates in the last days. But I am not using that theme. Is it possible that it has to be removed and not just not used? I find it odd that themes/plugins/etc that are not is use should upset things, but I am prepared to believe it (just barely).

Having raised this issue to begin with, all I can say now is that today’s exact situation with everything updated, no plugin ring-ins, all is fine. It’s almost embarrassing, and yet I swear the issue was there and causing annoyance.

That’s where I am now, but I am sure there is more to this story, as others are certainly seeing what I was.

4 Likes

I realize you ran cleanup multiple times, but did you upgrade Docker to the newer version since your version is deprecated?
Clearing browser cache sometimes helps.

I have to admit, your problem was an odd one at best. So is the problem cleared up on all the sites that were experiencing it?

I tried to repro on my site trying several methods, but was unable to. Everything worked as it should. Hopefully your problem doesn’t return. :crossed_fingers:

1 Like

It’s absolutely still a problem on https://caddy.community.

Go to literally any help thread while logged in, where the user used our template. Select the word version, and the quote button appears. Then select the whole line, it doesn’t appear.

Like I said earlier, the symptom is very clear. The problem is when any HTML tag boundary is crossed in the selection, it doesn’t let us quote.

1 Like

First off, I’m not familiar at all with Cady. From what I understand, you cannot quote from a template, but text outside of the template you can. Is that correct? Just trying to get on the same page. :slightly_smiling_face:

Does the problem below have anything to do with the quoting problem you’re experiencing? I notice a rendering problem in another template one of your users is working on. Maybe the quote problem is related to the template problem?

There is more to it than that. On your forum it is impossible to “Quote” any code text (whether on its own or selected together with non-code text).

What happens when you remove your code highlight settings? When I remove the hljs classes, spans and the pre tag around a code block, “Quote” works. Obviously the code doesn’t look right…

1 Like

No, I was only mentioning the template as a consistent fixture to talk about. But it’s a problem everywhere.

Completely unrelated. Caddy is a web server, and it can render markdown and Go templates to html as one of its features. That thread has nothing to do with Discourse itself, it’s a question about Caddy.

Right, which is consistent with my hypothesis that it has to do with HTML element boundaries.

hljs works by lexing the code and outputting HTML spans with classes for each type of token. This means a code block will often not be one contiguous HTML element, but be composed of many spans to provide colours. This is definitely not an hljs issue.

1 Like

I’m not sure it is consistent. It’s not possible to “Quote” any characters in code text in Site served by Caddy looks different to my HTML when open from disk - Help - Caddy Community (i.e. even within the code tag boundary). Except for the word file_server on the occasion where it is not surrounded by pre tags - that works all right for whatever reason.

OK cheers. I’ll give up now :slight_smile:

1 Like

Something is wrong with caddy.community, specifically. I tried to reproduce the reported issue on meta, try, review, a customer site and a self-hosted site, and quoting multiple lines worked everywhere. I’m not sure how the caddy site is only broken on this one specific functionality… but it is.

Although, I see another problem on the caddy site is this CSP error in the console: Refused to load https://caddy.community/google-universal-analytics-v3.js because it does not appear in the script-src directive of the Content Security Policy.. The underlying issue is that the path to the script is wrong, it should be ../assets/google-universal-analytics-v3-HASH.js.

3 Likes

Hey guys,
just found this topic after I made my bug report:

A successful rebuild should indeed fix your issues with quoting.
My misconception was, that I thought upgrading via /admin/upgrade is doing a rebuild too.

1 Like

Shouldn’t we actually try to find out why this even broke in the first place rather than blindly rebuilding? What’s to say this issue doesn’t return? Where did this regression come from? Was there a problem with a version migration script?

2 Likes

Blindly rebuilding is often the solution, much like blindly rebooting often solves problems. You’re welcome to sleuth the cause of the issue, but the solution will be the same.

1 Like

I’m getting the same thing on one forum (but not the other newer one).

Have tried rebuilding a couple of times but no joy.

It seems to happen when there is a html tag inside what you want to quote - so if you want to quote a single paragraph, it works, but if there’s something in bold or you want to quote more than one paragraph, it doesn’t.

Interestingly, if you log out, and the ’ share quote visibility’ is set to anonymous, it works for those not logged in (or seems to anyway). So I am guessing this could be what it’s related to? That is a fairly new feature I think?

1 Like