Rake aborted message is showing when installing vagrant development


(Gurjyot Singh) #1

I am following this installation guide to install Discourse on localhost. Everything was working as written in that guide but then as I types this command,

bundle exec rake db:migrate

I got a message that “rake aborted”. The complete message is below, please tell how to fix this?

rake aborted!
ln: failed to create symbolic link '/vagrant/public/plugins/discourse-narrative-bot': Protocol error
/vagrant/lib/discourse.rb:27:in `execute_command'
/vagrant/lib/plugin/instance.rb:449:in `activate!'
/vagrant/lib/discourse.rb:146:in `block in activate_plugins!'
/vagrant/lib/discourse.rb:143:in `each'
/vagrant/lib/discourse.rb:143:in `activate_plugins!'
/vagrant/config/application.rb:178:in `<class:Application>'
/vagrant/config/application.rb:26:in `<module:Discourse>'
/vagrant/config/application.rb:25:in `<top (required)>'
/vagrant/rakefile:5:in `require'
/vagrant/rakefile:5:in `<top (required)>'
/home/vagrant/.rvm/gems/ruby-2.3.1/gems/rake-12.1.0/exe/rake:27:in `<top (required)>'
/home/vagrant/.rvm/gems/ruby-2.3.1/bin/ruby_executable_hooks:15:in `eval'
/home/vagrant/.rvm/gems/ruby-2.3.1/bin/ruby_executable_hooks:15:in `<main>'
(See full trace by running task with --trace)
vagrant@discourse:/vagrant$

I also looked at this post but still couldn’t figure out the problem.


(Gurjyot Singh) #4

I have tried git pull to get latest and then went ahead by doing the complete process again but getting the same rake aborted message.


(Jeff Atwood) #5

Aha my bad @sam … not related… your problem is here

ln: failed to create symbolic link '/vagrant/public/plugins/discourse-narrative-bot': Protocol error

Why is “vagrant” being referenced here? This is not an install, this is a development environment.


(Gurjyot Singh) #6

So what should be done, I am quite new to Discourse and trying to set it up on localhost to understand how it works.
What should I do with vagrant to fix this issue?


(Jeff Atwood) #7

@techAPJ should we update the blog post? Perhaps have the blog post point to meta #howto topics?


(Gurjyot Singh) #8

Any update on this? I really wanna test Discourse but have no idea how to fix this issue.


(Arpit Jalan) #9

Added on my list to look into. :memo:

It might take us some time to update the blog post. In the meanwhile try some other guides available here on meta?


(Gurjyot Singh) #10

I tried every tutorial which you mentioned but none worked for me on my Windows PC. Even searched Google for Rake Aborted issued and ground methods but those also didn’t worked.

Now, I am just waiting for your reply about the updated Blog post. :slight_smile:


(Gurjyot Singh) #11

Hello, just wanted to know about any update on this matter?
Actually, we want to test Discourse to get our project on it as soon as possible.


(Mittineague) #12

I had varying degrees of success and problems installing Discourse on my Windows 10.

What - knock wood - has worked best so far is to

  • install a virtual machine (currently I’m using VMware)
  • create a guest using Ubuntu as the server
  • follow the “howto vagrant ubuntu” instructions

I am far from being a sys op and any success I ever have tends to feel more because of luck than actual knowledge. But installing into Windows 10 was a lot more hassle for me than installing into Ubuntu


(Arpit Jalan) #13

I have been working on more priority tasks, as I said earlier, it will take me some time to get to it.

In that case, I suggest you install Discourse on cloud following our official how-to:

discourse/INSTALL-cloud.md at master · discourse/discourse · GitHub


(Gurjyot Singh) #14

Thanks for your response, I’ll try that. :slight_smile:


(TzeHsiung Wong) #15

for anyone who got here from google search and unable to get it working based on the above, this is what i have found to help solve this issue on windows 10:

basically is just to run the cmd you’re using as administrator and run the rake command