Random users usernames not showing on posts

Is there any setting I’m missing that would cause some users usernames to show on posts and not others? e.g. SailPoint IdentityNow VS Code Extension Now Available - #9 by tranetechnologies - Announcements - SailPoint Developer Community Forum

1 Like

You’ll forgive me I hope for being unsure here, I’m not actually “working” at the moment :rofl:

Do all of the usernames that are not showing up match the firstname_lastname pattern?

IIRC Discourse suppresses display of usernames in the specific case where the Full Name “matches” the Username.


Then as far as I’m concerned, you’re just a regular like me :slight_smile:

Yeah, wow I never noticed it did that…is that documented somewhere? and is it able to be disabled?


this looks like the applicable code to override:


I hope to one day find the time to learn to build theme components. For now I just hid all usernames for consistency’s sake.

1 Like

They are hidden because it seems silly or noisy to display a name twice in a row. I believe that there There is a setting that you can change to have it display anyway.

There are some similar settings with “suppress” I in them that do similar things in other circumstances, but I can’t find the one you want on my phone right now.

1 Like

i think it may be prioritize_username_in_ux ? :thinking:

1 Like

No, this setting doesn’t override this behavior :slight_smile:
I didn’t find a setting to display both the username and name when they are identical (minus spaces) and it might require a component or plugin.

1 Like

I think this theme-component could help


This was exactly it, thanks @Moin!

I agree with you, and at the same time it’s inconsistency UX to display most as name > username > title, and on seemingly random (to the uninitiated of this feature) not show some usernames and it just be name > title.

I’m glad this feature exists for my use case! As usually, just showing how incredibly malleable this platform is to one’s needs in customizing their community.


To anyone who finds this later, this is the answer to my question:

But this is the solution for adjusting the behavior:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.