Reactions Not Showing Options for Some Users

We’ve encountered this before, but it is now starting to effect additional users with more recent updates.

Some users (All using FireFox Latest build 122.0.1 (64-bit)) have no reaction options on posts, only Heart. Hovering over a post Heart only shows the Alt Text.

This does not seem to be a Discourse plugin/install issue. Once a user is effected (I am on ONE PC (brand new out of the box)) it affects this user on ALL DISCOURSE instances.

This is a new out of the box Surface Pro, I have only Heart reactions on two separate self hosted installs (both updated last week), AND same here on meta, ONLY Heart.

I can open Chrome on the same pc and I have all reaction options.

I can open Firefox on a different pc and my Android phone and I have all reaction options.

This only seems to affect a very small subset of users, but myself and another user who did have access to all reactions have now seen the issue as of this week.

I know this is a needle in a haystack hunt, but thoughts?

Do you see any errors in the browser console?

1 Like

Maybe it’s a problem with Firefox? Also, I don’t have the reaction button either, and I’m on an iPad with the Google app… Alternatively, it could be a trust level thing but that’s highly doubtful.

That’s my working theory, but considering it effects the same version of firefox differently across different machines under the same account, it’s a head scratcher

Maybe it’s something else. In my last post, I noted that I didn’’t have the reaction button either despite the fact I’m using Google. I’ll ask my friends there later.

Edit: Shows up now!

From an additional user

tell the user to try private browsing. it’s probably a firefox extension.

Just tried that, same issue

Have you reported this issue to the firefox bug tracker? It may be an issue with the Firefox Browser.

1 Like

It is the next step, but since it only effects discourse this is my first stop.

When discourse can say, yeah, it’s a FF issue, and here’s what is causing it, I can push a bug report with more detailed information

Almighty, Latest version of FF fixed it for me, 123.0 (64-bit), Checking with the effected users

Checking with all effected users, 123.0 FF seems to have fixed this issue, one user had been experiencing it for over a year.

1 Like