Rendering of quotation marks


(Florian) #1

I’ve recently converted a large forum to Discourse and now noticed something, I’d like to change. We have many posts where quotation marks are used to denote small snippets of code or parameters to specific functions. Those are then often copied by members of our support community to for use in the software.

Those where not always enclosed in code tags, but instead using double or simple quotation marks, e.g.,

Parameter: /e, /select, “%_path%”

The problem here is, that quotation marks entered as " are automagically rendered to their open/closed forms as you can see above. This, unfortunately, breaks all the examples that are formatted in this way (it’s invalid syntax in the software).

Is there a way to prevent the automatic rendering of open/closed quotes “” and use the vertical form " instead by default — without putting everything in code blocks?


(Gerhard Schlager) #2

You could disable the enable_markdown_typographer site setting.


(Florian) #3

That’s just great :star_struck: Thanks a lot, Gerhard!