Straight quotes

I tried to set

" " ’ ’
in the Typographer replacement pairs for straight quotes.

That would have forced the Typographer to keep the straight quotes, while continuing to do all other usual changes (em dash tm, etc). Users would have had to specifically type curly quotes for text but that’s fine.

Unfortunately I cannot enter the same value twice in the replacement pairs field.

So I had to deactivate the typographer altogether. Was there another way to achieve our goal (not have code quotes modified)?

PS. I can see here my double quotes have remained straight but the single ones haven’t so I guess it is possible to do?

1 Like

At this time it does not appear to be possible to replace the fancy quotes with straight quotes using the markdown typographer quotation marks site setting. The original intention for that setting was to support languages such as German and French that would have four different quote characters.

With the enable markdown typographer site setting checked, the double quotes will be rendered as straight only when there is a space directly after the first double quote, or a space directly before the last double quote.

Straight quotes:

  • " "
  • " foo"
  • "bar "
  • " foo bar"
  • "foo bar "

Fancy quotes:

  • “”
  • “foo”
  • “foo bar”

Single quotes (aka an apostrophe) will always be rendered fancy.

Is there a particular reason you are looking to replace the fancy quotes? For the purposes of sharing code, we suggest using code blocks to bypass the fancy formatting:

Using the following syntax:

'single quote'
"double quote"

Will produce:

'single quote'
"double quote"

Thank you. People don’t think of using the code blocks so it’s hard to guess if they made the mistake in their code or it’s the typographer that converted straight quotes.

Nevertheless, I will check with my tribe and see if we can get them to use code blocks


Code blocks should be posted as CODE BLOCKS, not text!

  • indent 4 spaces
  • use code fences (3 backticks)
  • use the code formatting button on the toolbar

Treat the underlying disease, not the symptoms :wink:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.