Replies to discobot tutorial flagged as spam

I’ve seen a couple of users signing up to our site and having their private messages with Discobot flagged by the system as inappropriate:

This is what appears in the review section.

This is not ideal, as users get a bad impression from our site once they receive this message:

This happened to several messages from a couple of users while doing the discobot tutorial, which ends up being a terrible experience, especially for a newcomer.

I’ve checked this post, but those users haven’t posted anything on our site yet (apart from replying to Discobot), so I don’t think changing the value of newuser_spam_host_threshold is the solution.

Any ideas?

1 Like

What version of Discourse is your site on?

Is there anything in common with the posts that have been flagged as inappropriate?


2.5.0.beta2 (86690155b3)

Reproduced the issue again with a different user. It seems any reply with an emoji triggers the system flag. This happens before discobot asks for a test flag.


Unless you can reproduce it here or on, this is due to unusual settings on your instance.


Not that I can find. A recent new user got flagged for both his emoji post as well as the onebox post, so it doesn’t appear to be related to content. Akismet isn’t installed. It happens for multiple IPs. It seems to happen only with new users? Posts are flagged with 63% badness consistently and the user gets

In addition to Topic List Previews and a custom plugin that doesn’t look suspect to my naive eye. I don’t see in the logs where the posts are getting flagged, so I’m not sure where else to look for an explanation. What are the things that can trigger a post to get auto-flagged? Where else can we look?


So you can’t reproduce it on

That’s correct.

And I can’t reproduce it on the broken site with an existing admin user. It seems to have something to do with it being a new user. Maybe it’s breaking because they’re TL0? But that doesn’t make much sense.

I’ve looked at all of the non-default settings and see none that seem likely to cause this problem.

Right now the only solution that I have is “delete your forum and start over again” or maybe “reset all of your settings to their defaults.” (I will first remove the two plugins, but they seem like unlikely culprits. I guess I’ll try that as soon as it’s not too disruptive to the community.) I’m asking for some ideas of what I can try next to determine what’s causing this.

1 Like

There is a site setting which, when triggered with matching text, sends a post immediately to the flag queue based on that matching text (regex). Sam added that in the bamwar fighting days as I recall, and we used korean character sets as an immediate trigger for example? Because those never appear here (and I believe it is checked for new / TL0 users only, thus fairly safe).

That’s all I can think of.

edit: or watched words, would be the same thing…

1 Like

Searching . . . . Maybe you’re talking about auto silence first post regex?

That sounds just like what I’m looking for! Alas, that ain’t it. :crying_cat_face:

1 Like

Good news, we were able to find the root cause of this issue.

Actually @pfaffman was reviewing our site settings and found out that we had changed a few default settings that had caused the issue.

For other users who might have this issue we had added several words to the Flag admin setting admin/logs/watched_words/action/flag including our own brandname pricemate along a few others.

We also changed settings like min post length among a few others to a very low value which could have also caused some issues. After removing those words and reverting the Posting settings to their default values the issue disappeared.

Kudos again to @pfaffman and thanks for helping us with this!