Requiring parent tag does not effectively prevent users from adding tag without parent tag present

Sorry, I have to recategorize this as a UX issue. I noticed that the tag group to which the filters tag belongs (mistakenly) required a parent tag in order to be used. So the behavious I describe below is not a bug but I would say there is room for improvement UX wise.

To summarize the problem described in more detail below: if you require a parent tag to be present for a tag from a certain tag-group to be used, the tag can still be added (or it looks like it), causing some strange behaviour.

Taking it even one step further, one might reason why I ended up having a parent tag required where there should have been none. Looking at the tag group management page, I can see why that happened: I mistook the parent tag field for an “add to group” field:

Not sure if or how this could be improved, but I thought I’d mention it. Intuitively, I would position the parent tags above the child tags, but I can’t rule out the possibility that the same could happen if it had been there. So I think what I’d do is move the parent tag field down, either below the “Limit one tag per topic…” item or to the very bottom. That way, it is clear that that field has no business with the main tags field.

But back to the original strange behaviour reported below:

This issue probably somehow connected to the one about Adding tag to two or more groups breaks the tag but I’m filing this one separately because the symptoms I’m seeing are different.

I have tried to apply a tag called filters (which belongs to exactly one tag group) to a topic in a public category but it does not “stick”. I can select it, add it, click the :white_check_mark: icon to save and the tag is correctly displayed under the topic title. But as soon as I reload the page, the tag is gone again.

In the revision history it looks like this:

First I added the filters tag:


then I added two more tags but since the filters tag was not really there, it was simply replaced by the new tags:


Then I tried adding filters to these two tags. The result is that the two tags stay but filters disappears when the page is reloaded. In the post revisions, it looks like this:


Yes, you’ve seen right: there is no revision at all. And the two tags, which defacto still stick to the post, are also gone in the revision… :woozy_face:

Not sure if related: when searching for tags (while adding them) only full hits are shown, i.e. in order to find the filters tag, I need to enter filters, filter yields nothing.

1 Like

Yes, I think this is related. In fact, it might be the easiest way to to solve the worst part of this issue: Most of the strange stuff described in the OP would be prevented if searching for a tag that requires a parent tag yields no results if the parent tag is not present. Currently, it does find the tag in question if the search string matches it 100%.