[Resolved] Getting Discourse going again after Vultr server hard restart


(Joel Zaslofsky) #1

tl;dr I just broke our Discourse install over an hour ago and need urgent server/docker/container/SSH help to get our paid community site running again. Please DM me if you can help tomorrow (Sunday in North America) so we can discuss me paying you for your help (assuming you don’t help for free).

Here’s the context: I got an admin notification in Discourse that 6505 email jobs had failed and, according to my apparently misunderstanding of this meta thread, I believed restarting my Vultr VPS server could be the solution.

So I logged into our Vultr VPS back-end admin panel, pressed the server restart link, confirmed I wanted to do a hard restart, the server started back up in seconds, and then every forum page I or anyone else has tried to load since has given me a generic “Problem loading page/Unable to connect” message. I have a feeling this has something to do with dockers and containers not reconfiguring/restarting properly after the hard server restart, but I’m in over my head on identifying the root cause and solution.

I can help you SSH for access if you need it. I’m feeling like a giant freakin’ idiot right now and you could help me save face with the community if we could resolve this quickly. Thanks in advance.

(Tagging @pfaffman because it seems like you’ve been helpful for these kinds of things in the past).


(Joshua Rosenfeld) #2

Quick reminder - paid jobs need to be in the #marketplace category, not #support.

Have you tried SSHing into your server and doing the following?

cd /var/discourse
git pull
sudo ./launcher rebuild app

(Joel Zaslofsky) #3

Thanks for pointing me to the right place, Joshua. I’ve changed the category from support to marketplace.

I tried to follow some tutotials to SSH into my Vultr VPS server and couldn’t get my PuTTY session to connect. I’m in over my head here which is why I mentioned I’m willing to pay to have someone else step in, troubleshoot, and resolve my problem. Free is always a fantastic price, too.


(Stephen Chung) #4

You’re not gonna be in a lot of luck if you don’t even have SSH access… Maybe call up Vultr support? They should at least get you thru with SSH, right? Otherwise what good is a VM except a weightless brick in the cloud?


(Joe) #5

This is a shot in the dark. I don’t know anything about Vultr

However, on Google Cloud, VMs default to Ephemeral IP addresses unless you reserve a static IP.

An ephemeral external IP address is an IP address that does not persist beyond the life of the resource. When you create an instance or forwarding rule without specifying an IP address, the resource is automatically assigned an ephemeral external IP address.

Ephemeral external IP address are released from a resource if you delete the resource. For VM instances, if you stop the instance, the IP address is also released. Once you restart the instance, it is assigned a new ephemeral external IP address.

If the VM IP differs from what’s in Discourse settings nothing will load on the front end.


(Joel Zaslofsky) #6

Thanks for your replies everyone. @nixie came to the rescue and I’m back up with Discourse again.


(Régis Hanol) #7