Restored a backup on a test setup -- image doesn't show in post unless I change resolution

Kind of an odd situation, but I restored a backup to see how it looked on a test setup of Discourse and an image in one of the posts that was sized at 50% looks like the below situation. I tried “rebuild html” but that did nothing. Strangely, if I change the resolution from 50% to ANYTHING else it works (e.g. 49%, 51%, etc) and shows up just fine in the post. I posted the html below. The image preview looks fine while editing but just won’t load??? So weird.

![image|400x500, 50%](upload://4WKdjbSdihW1G9uHJhVB9jJdzcy.jpeg)

Any Ideas?? Thanks!


Did you see the following message at the end of the restore?

Posts will be rebaked by a background job in sidekiq. You will see missing images until that has completed.
You can expedite the process by manually running “rake posts:rebake_uncooked_posts”


Must have missed that message – I entered the web_only app and tried a rake posts:rebake but that did nothing. I will try what you posted. Thanks!

Ok tried the manual process and didn’t work (said “0 posts done!”). Would the fact that I’m running a two-container setup be a problem?

No, it shouldn’t.

Are your uploads stored locally or on S3? Did you restore a SQL-only backup (.sql.gz) or a full backup that includes uploads (.tar.gz)?

Uploads all stored locally.

Full backup restore (.tar.gz).

Just to be clear – if I click on the image, it pops up but it won’t show embedded or whatever in the post unless I modify the resolution it was set at upon restore.


Just tried from another machine using Firefox instead of chrome and it comes up just fine. Had some weird caching going on with Chrome and was able to fix it with this…

clear cache for site in Chrome

Thanks for the help @gerhard !!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.