Screen overlay: missing gutter in UI? Only on Edge

I’m getting a text overlay when I display my user activity or notifications.

This is only when using Edge, a fresh instance I just fired up. To my knowledge there are no tweaks on the setup, fresh out of the box. It shows when I click on Notifications or Activity for the user I am logged in as.

It does not happen when I log in from Chrome or Netscape. I’ve been looking for any other place where gutters are not working… for example they are working fine on the Admin Plugins page.

Examples:

Another example:

What version of Edge? Make sure you are on latest.

1 Like

I am currently on 42.17134.1.0. Windows update says this is the current version as of yesterday. It is still doing it today.

1 Like

Here’s a new clue, and it’s a weird one. It isn’t Edge at all, this is something about one particular user.

I’m piping inputs to our current home-grown mail list system into Discourse and using an ‘Input’ account to process them then switch topics into our main categories. The input stream goes into a category which only the Input account can see.

To spin this up I have three accounts: My personal account, the Input account and a Test user account.

Only the Input account has this problem, and it happens on multiple browsers. The topic should probably be edited to reflect this new understanding.

One more clue… the Input account also does not show the latest / unread text next to the category listing in category/latest mode.

So… what could possibly be different for this user to affect the UI?

1 Like

Another clue on this missing gutter issue. Please note it does it on all browsers, not just edge as first suspected.

When I impersonate this ‘Input’ user from another login the problem does not occur, the user activity and notifications menu gutters work fine.

I have not found any other functional areas where this is a problem, including the settings which seem very similar in design.

I tried turning off various settings, some of which I had recently changed, to see if it would change something. No change.

I am using SSO for all users, but a unique SSO for this user. I have one other user with the same unique entry… he is not experiencing this issue.

Have you updated Discourse recently? Your issue may have been fixed a few weeks ago

3 Likes

My instance was updated on July 15th. 10 days after this topic was closed… wonder if it made it into that build?

That bug does indeed seem to be the exact situation. I would make a comment on that topic but I see it is closed… I’ll be glad to share what I can to help pin down the triggers on my end.

1 Like

The original bug was specific to Edge, and the fix for it was also specific to Edge (see commit). But if this happens on multiple browsers, then the issue is something else. Maybe the issue only happens with users that have a specific role? Can you create a second user account, with the same roles as Input and see if issue can be reproduced?

Yes! I was able to duplicate the issue with another user. They are now both set up as follows:

And the test user view looks like this:

Now that this user is ‘broken’ I can’t get that user to work properly again. I reset the permissions back and the issue remains.

How can I help with debugging?

So now the layout is broken for both users?

That is correct. Both users exhibit the lack of gutter on both IE and Edge. In the past I tried Netscape and Chrome also… it would probably help to confirm that they are also both broken. I’ll test that.

Hi Keith,
I can reproduce this locally on IE15 / Windows10 only if I revert the commit that fixes the issue. So, most likely, your instance isn’t up to date. Please make sure your instance is up to date and try again.

2 Likes

I’ll watch for that update… the last was July 15th… I think the commit was July 10th. Hopefully this update was just in testing then… Thanks.

2 Likes

My instance of Discourse was updated 4 days ago and this issue still remains. The issue is currently observed on Explorer and Edge, but not on Netscape or Chrome. It only affects these two users, the one where I first say it and the test user where I created the same conditions as described above.

image

I understand that my Discourse version is still pretty old… I am on Discourse 2.3.3.

So as I think this issue was resolved in mid July it has probably not flowed down to my instance on discoursehosting.com.

3 Likes

2.3.3 is just one week old, this is more about whether the fix has been backported into stable (looks like it hasn’t, maybe @pmusaraj can do that?)

Sure, it’s a one-line fix, now backported to stable.

4 Likes

Thanks @pmusaraj!!

@Cardinalflyer Your forum has this fix now.

2 Likes

And it works! Thanks very much to all!

2 Likes