"Search" keyboard shortcuts conflicts with Polish diacritics input

Hi! First, thank you for creating such a great software and community!

But to the point: When I type (and it’s the way everyone in Poland types it) Polish diacritics “ś” on my keyboard by pressing right alt + s, search popup pops up, capturing the text that follows. This isn’t a big problem, but it’s very annoying. Is there a way to change it or turn it off ?

1 Like

There was a fix for this a couple days ago, you should upgrade:



I just upgraded today and this problem also appears on this site, so this upgrade probably caused the described behaviour to appear (right alt is, I suppose, equivalent to ctrl+alt).

1 Like

Hmm. I can’t get any alt-S to search. Perhaps you should send @sam your keyboard. (Obviously not a real solution, but he might be able to help.)

More specifically. sharing your specific keyboard layout would likely be helpful. Please don’t ship Sam your keyboard :package:.


It’s Polish QWERTY – with AltGr (and I already wrote to Sam).

One more thing – it probably only affects Windows, as it maps (as I understand) AltGr to ctrl+alt; I tested Mac a moment ago and it’s ok there.


Grrr, this is a hard one to win, CTRL+ALT+s was a change I made cause CTRL+s conflicted with Firefox.

Can I detect AltGr from JS so I can still keep this or do I need to move the shortcut?

We use this keyboard shortcut to enter to the text “ś”, which can be entered with the following combinations:

  • Alt + S
  • CTRL + Alt + S

It pisses me of when the search engine activates at that time - one of my users drew my attention to it. We very often use such signs, so I would like to ask you to change this :slight_smile:

1 Like

I am fine to change it but its hard to find something that does not conflict… that is all…

CTRL+ALT+F anyone?

1 Like

Even CTRL + F (without ALT) would be good. It doesnt affect at our language.

I have an idea of how this can be done for the benefit of everyone.

By default - the same keyboard shortcuts for everyone.

Someone wants to have shortcuts suitable for their language - you can add an “locale_shortcuts = pl” style option to config and for other languages, and so on.

It’s hard to reconcile everyone in terms of keyboard shortcuts, so I think it doesn’t make sense to do it universally for all languages.

CTRL+F is search in most browsers. That triggers our search for me.

1 Like

It works on long topics but short topics when you are composing you can not use that shortcut cause you get in page search.

Anyway changed it to CTRL+ALT+F for now so this is resolved