Sendgrid SMTP Issue - Say it works, nothing is delivered

Hello, I have installed dscourse on an EC2 instance. I am using sendgrid as my SMTP pointed at 587 using the apikey authentication method as recommended in the docs

Previously I was unable to connect, then specifed the port in the app.yml and according to discourse-doctor the emails are able to send and I am able to telnet using that port while SSH’d into my instance. However, no email is actually sent, and nothing is being received, even when using the mail-tester emails.

When I check the logs (when trying to send through the actual website, I see this:
Delivered mail 1ed931d5-3181-46a1-86f0-1b18b6366020@forum.redactedthisisactuallymydomain.com ( 628.3ms)

Sendgrid does not seem to have any requests in its logs.

My outgoing ports on my EC2 instance are completely open.

Not quite sure what I’m missing. Also tried using 2525 as the port, no success.

Anybody have any ideas?

1 Like

I ended up just moving to mailgun and it worked perfectly. I am guessing then that there was just some issue with the domain registration, but honestly, still not sure.

1 Like

Yesterday I also demoed a new version using sendgrid as smtp, but it looks like email was not sent!
So it looks like the fault isn’t just yours. :roll_eyes:

Hmm, perhaps SendGrid was having issues on their side. I couldn’t find anything in their logs, but also was a bit confused by their logs so who knows. The good thing for me was that we weren’t set with any SMTP yet so the switch was easy. Might have also been some issue with the domain registraion stuff, because I was getting weird errors when setting that up with them now that I’m thinking of it (click veriy, one said it worked the other said it didn’t, clicked verify again later, and it switched) so perhaps if anybody else comes across this, make sure that your DNS stuff is working correct with them?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.