Show Full Names in Emailed Previous Replies


#1

The users of my forum want real names pretty much everywhere. I prioritize real names, but when previous replies are sent by email, only the usernames appear:
image

Is it possible to change this myself using the template editor? I suspect this is a lower level setting than what can be modified with the editor.


(Jeff Atwood) #2

That doesn’t look like our normal email formatting to me?


#3

I’m on v2.2.0.beta1 +4 and I don’t think I’ve modified any part of the previous replies template - I don’t actually know where I would do that. That screenshot was taken from Gmail, and it looks the same to my eyes in Thunderbird.


(Kane York) #4

That’s the text-only email format, which contains the post markdown. Fixing it for the prefer real names setting is valid.


#5

It seems odd to me that both my Gmail account (in IE and Firefox) and a different email account in Thunderbird display the plain text version over the HTML. I receive lots of HTML email messages in both places. Using the Gmail app on my iPad, it displays the HTML version.

I temporarily removed the customizations I made to the User Posted Email Template to see if maybe something I did there was to blame. However, Gmail still did not display HTML even with the defaults. Neither did the account I use in Thunderbird.


(Jeff Atwood) #6

This is very weird and I would not expect that to be happening.


#7

HTML issues aside, is showing real names in previous responses something that is likely to be changed in a future release?


(Jeff Atwood) #8

I am unclear, I can’t tell based on the strange screenshot you posted. But for full HTML emails, it should respect the site settings, yes.