Site keeps showing "Dark" color palette even though I set it to "Light"

I cannot seem to get the correct colors to show on my site. I have selected the “Default” theme with the “Light” color palette but the site is still showing a dark color scheme. I even tried installing a new theme – “Mint” – and using the “Light Mint” color scheme, but to no avail. You can see from the attached screenshot that the site is dark with either theme.

Not sure if this is relevant but I am currently on the 14 day free trial of the Discourse Standard Plan.

I have also toggled my browser’s dark mode on and off and that does not seem to be the issue.

From /admin/customize/themes , the default theme, Dark, will have an asterisk - * - next to its name. Open it and you can disable the box Theme is enabled by default.

Then you can go to an alternative theme and set it to be the default.

1 Like

Is your operating system set to dark mode?

If you check the site setting default dark mode color scheme (direct link to the setting) that’s set to a dark color scheme. If you change that setting and see your colors change once you refresh the page, then you can confirm that you’re still in dark mode.

2 Likes