Site stopped working "without reason"

I’ve installed a Discourse forum like, 4 years ago, I think, in a DigitalOcean droplet… Although a problem here and there, was everything ok. I’m not really active in the forum anymore, but still visit it once or twice a week (have plenty of friends I made in the forum) and do the “tech things” when needed.

Long story short: Last weekend the site went down. Monday (yeah, in Christmas) a friend contacted me that the forum was down for 2 days. I then checked everything, and ends up that the our current “sponsor” 'forgot" to pay the DO host, so it obviously went down. To don’t let the other users bad, I paid it myself.

But the site was still down, so I started checking everything. As I still can acces by ftp or ssh, I looked at the domain, but is active. checked and rechecked the configs in DO and in the app.yml, but nothing seems to have been changed… Updated everything by SSH, rebuild it several times, disabled and enabled SSL, tried even going back a backup (either the Discourse one as DO one), nothing.

Then I decided to try a ./discourse-setup and it returns an error trying to connect either to ports 443 (“Port 443 of computer does not appear to be accessible using hostname”) and 80 (“Connection to (port 80) also fails”). I’m pretty sure no change was made in the configs (yeah, I’m the only one with access to DO and SSH), and the only reason I can imagine was the DO freezing the site because of the payment. But, since I paid it and can access by ftp and ssh…

Where did you buy the domain? Is there any chance someone forgot to pay for the domain renewal too?


This is very long shot but when DO shuts down a VPS they power off it totally. So just paying and powering on isn’t enough. There is need to restart every service one after one, and specially everything that is port/firewall things.


From what I see, is available till 2024-07.

However, it appears that there are some problems with the Nameservers or DNS. :thinking:


Hosting24/Hostinger. I checked and it’s active

Gonna try, although afaik I restarted everything :confused:

That’s bothering me, but i checked it twice and seems correct… But gonna redo that again too, just in case…

Did you change something recently? It seems your domain can’t resolve to an IP and has issues with nameservers.

Not an expert. Ensure you use the right nameservers and your DNS entries look good (without duplicate). :thinking:

EDIT; It looks like you fixed the domain! :clap:
EDIT2: Unfortunately, you have some trouble with theme components or plugins, feel free to use the safe mode if you need access to your forum (it works for me).


No ideia “why”, but I deleted the old nameservers and created new ones (with the same config!) and it worked!
Thank you guys!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.