Site unreachable after failed attempt to upgrade


(Alexandra) #1

Hi guys,

I justr tried the automatic upgrade from 17beta6 to 17beta7. The upgrade didn’t succeed and the last messages I had on the console screen were:

Bundle complete! 99 Gemfile dependencies, 177 gems now installed.
Gems in the group development were not installed.
Bundled gems are installed into ./vendor/bundle.
bundle exec rake multisite:migrate

As expected, Ningx gives me an error message when I try to access the site:

504 gateway timeout

I ssh-ed into the server but I really don’t know what to do next. The docker daemon does not seem to be running:

alex@community:/var/discourse$ ./launcher logs app
Cannot connect to the docker daemon - verify it is running and you have access

Could someone please advise how to get the site back up and running?

Thanks!


(Joshua Rosenfeld) #2

Have you tried rebuilding?

After ssh’ing to the server,

cd /var/discourse
git pull
./launcher rebuild app

(Alexandra) #3

Thanks for that Joshua. I am rebuilding now and keeping my fingers crossed …


(Alexandra) #4

Whew, the site is back up (and I have a few more grey hairs …)

Thanks again Joshua, you guys rock.


(Dan Claudiu Gavril) #5

Same thing happened to my installation while upgrading from 17 beta 6 to beta 7.
Had to rebuild app to set it back up…

Thanks @jomaxro


(Régis Hanol) #6

FYI: the failed upgrade was due to a nasty bug in a library we use to execute JavaScript on the server-side. It has since been fixed.