Site won't load / can't open in safari / other issues

Hi all,

A few issues here I would appreciate immensely if someone could help me out with as this is time sensitive.

My forum is set up on the site as a subdomain to my main website. It’s

I’m hosting the site with DigitalOcean, and followed all the steps in setting it up correctly.

  1. It almost never opens in Safari, as I get a message saying "Safari can’t open the page “” because Safari can’t establish a secure connection to the server “”.
  • I was suggested to clear my cache, which I did, and nothing happened immediately but then I tried accessing the forum the next day and it opened fine. It worked for the whole day, and then decided it can’t open the next day.

– Sometimes this happens in Chrome and Firefox too, although it seems to open at a higher percentage in these browsers.

— In any case, it’s clearly very disruptive to have to work like this without knowing if the webpage will open or not.

  • Now when I try to login, I just get a never-ending loading wheel. Before, the loading wheel would happen when I was log into the forum, but now I can’t even login.

I’m wondering if the forum was set up incorrectly in the first place, or if there’s someone who has had similar problems to what I’m going through… I’d really like to get my community up and running asap so any help here is greatly appreciated.

Thanks and I look forward to hearing back from someone who can help me out.


Your DNS is in a very weird state:

➜  ~ dig

;; ANSWER SECTION:    1800    IN      CNAME          3599    IN      A          3599    IN      A

What is the IP of the droplet hosting your Discourse instance?


The IP of the droplet hosting my Discourse instance is

How should I change the current way it’s setup there from your screenshot?

Thanks for your help here - I’m a total noob at this

You should delete the cname. Create an A record with

You need to visit the service where you handle your DNS.

In there DELETE the current CNAME entry for forum.

Add a new A entry pointing to


Okay - I deleted the CNAME entry for forum, and I already have an A record with that IP address - can I just leave that as it is?

Thanks for your help! Much appreciated

You need to have an A record named forum with that IP address. The CNAME is still listed at, so it’s unclear if you have done it right. It could be a while before they update their DNS servers.

I have an A record named forum with that IP address.

I have no CNAME associated with the forum anymore, so perhaps it just needs to take some time to update their DNS servers. Will give it a bit of time.


1 Like

Your forum is working fine now for me.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.