SMTP Not sending mails to Gmail

Hello everyone i’ve got a bit of a problem, the last few days.
My SMTP isn’t working, i’ve tried with Mailjet, SendGrib, MailGun.
I’ve checked over 100 times, that the information is the exact one, on the website.

It won’t send a email, in the admin section, where you can test the emails.
It says “Sent”, and nothing comes in, i checked the log for the Mailjet, SendGrib, MailGun, websites and it comes through, but doesn’t come to the client.

Any help is appreciated :smiling_face_with_three_hearts:

Read the email troubleshooting #howto and reply to each part of it.

Okay, i’ve tried again now, and didn’t work.

Did you enter email settings correctly?

  • Yes, i have checked it over, and over again.

Are your SMTP connections being blocked?

  • No, it connects to fine to MailGun SMTP.

Is the email domain correct?

  • Yup, i have changed it, so domain and email settings are same.

Still nothing works?

Can you see the email in mailgun account’s logs?
That’ll make diagnostics really easy.

3 Likes

Yes i can, and it says it didn’t got delivered.

What is the reason ?
Logs should be detailed enough!

Some possibilities that I can think of are:

  1. Configuration issue
  2. Bad domain reputation
  3. Invalid or restricted recipient email

Hey,
Just tested mine today and it works with Gmail (puts mails into spam folder but it something…)
This service called sparkpostmail.com , you can also find a guide with setup through search in forums here…

In my setup, it didn’t totally work until I put all the mailgun information in my DNS settings for my provider (Namecheap) and on the section that asks about how to handle my mail I selected Google as my provider (because I am using G Suite as my email provider for my domain.

Probably a terrible explanation of how I got it to work.

Who are you using for DNS?

I’m using Digitalocean and BOX.co.il for DNS mixture