Trying everything, no luck with smtp working

I have spent approximately 18 hours searching now.

I tried Google SMTP
Swismail SMTP SMTP

I have gotten TCP error, error 500, must start starttls
Tried ports 465, 587, 2525

I Did so much i don’t even know where to start to say it isn’t working for me.

It’s hard to guess what “everything” is means. Using the free Gmail for sending mail is against their terms of service. We’re you using regular Gmail? It’s pretty hard to get Google mark configured even if you are paying for it; there is a #howto for that, I believe, but I can’t find it quickly.

Have you tried a recommended smtp provider like mailgun? Have you tried Troubleshoot email on a new Discourse install?


Jay, you are right, I tried everything except MailGun and Mailgun just worked. I input the settings just like i did with every other platform I attempted and Mailgun just worked. God bless you and thanks


Great! Glad you got it figured out. Could you click the checkbox next to my post so that the issue will be marked as solved?

Welcome to the discourse community!

4 Likes Is it bad to use personal mail? If it will cause problems and spam in the future, I think corporate mails like work well with discourse.

How can I properly change my email address?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.