SMTPAuthenticationError - I don't receive mail from mailgun to setup the admin account

Hello, I’ve been trying to set up my Discourse forum, everything is fine except that I won’t get any mail for the admin account when trying to set it up.
I use mailgun, and everything is fine on that end in the DNS settings, with it showing “active” or “verified” in green colors on all the settings.
Checking the logs on mailgun it doesn’t show anything either.

I ran ./discourse-doctor and this is what it shows:

Does anyone know what I can do?

you’ll find some useful hint here: Troubleshoot email on a new Discourse install
Some port issue maybe are-your-smtp-connections-being-blocked-4 ?


I’ve tried solutions there and I’m kinda stuck, I even did a rebuild to make sure I didnt spell anything wrong, but I copy pasted everything during my setup to make sure I wouldn’t misspell anything.

This is the message I get when checking the port:

1 Like

Are you attempting to hosting this forum in the cloud, if so, which provider are you using? They may be blocking the requests.

1 Like

I’m hosting it on digitalocean with the discourse 1 click app.

1 Like

:thinking: could you try to authenticate
create a base64 encoded string

echo -ne '\0username\0password' | base64


openssl s_client -connect -starttls smtp


AUTH PLAIN withthebase64stringfromabove
1 Like

I take that back. It did initialize a connection to mailgun.


Where do I do this? I’m sorry I’m not a coder, just literally followed this youtube tutorial lol.


standard install


I see, I mean I’ve done it before successfully with the “1 click app” 2 years ago for another forum, and the only thing that I have trouble with right now is the email not going through :frowning: seems rather excessive to do it the hard way which I probably can’t anyways with this minor issue

Sorry I pasted the wrong youtube video, I updated previous post but this is the one:

1 Like

Ah yes, I understand the dilemma, but I’ve found the exercise quite rewarding down the road and on the other hand it’s very difficult if not impossible to follow every customization done in these 1’click installs so support is very difficult.
But you can try to see what’s wrong with the shell commands above in a terminal and find out what is missing from the host system.

1 Like

See Troubleshoot email on a new Discourse install

1 Like