[SOLVED] Stuck at verify sending domain - sparkpost

Hi all… i have tried to search for similar problem but still couldn’t solve this … hope to get some help here…

I am following the step to setup the Discourse One Click Application on Digital Ocean and use SparkPost as the SMTP server… but currently stuck at verify sending domain (this is my first time experience with SMTP… mail server etc)

Below is currently the setting for my domain … does it look ok? What are the steps that I need to do to actually verify sending domain? I am totally clueless… so any help will be very much appreciated

Digital Ocean Domain DNS


This is the verify sending domain part from SparkPost in case it can help

It looks correct to me, according to Sparkpost’s instructions. But this is a question for Sparkpost, not Discourse.


Thanks for your reply! I see… actually am not sure where to ask but since my ultimate goal is create a discourse forum… so i thought will start here instead… but will check with sparkpost as well after this

Actually am not even sure whether i really understand the whole DNS… nameserver thingy… i registered my domain with namecheap and found an old thread here where people are saying it’s better to use the namecheap nameserver instead

Since am new to all these… i just followed the tutorial on digitalocean and hence set the domain in namecheap (use custom dns) to direct to digitalocean nameservers. Am i making any sense here?

So by saying that it’s better to use the namecheap nameserver… does it mean that i should use the namecheap basicDns instead and don’t add any domain to digitalocean? How do i make digitalocean to recognize my domain then?

Don’t use DigitalOcean’s nameservers, no. Use Namecheap DNS and then edit the DNS records to add the SparkPost entries.


Thanks for your reply ! I dig deeper and found some older threads about namecheap… and end up with these DNS records that I set in namecheap. Also deleted my domain from digitalocean.

However… still can’t verify sending domain… i checked those dns at dnschecker and all seems ok except for the mail one (scphxxxx._domainkey.unggunapi.com) but i will check again perhaps after 24 hours and check with sparkpost as well later on if necessary

I will keep on updating here just in case it will help other clueless ppl like me in future

SOLVED !!! found this doc about setting SparkPost (i referred to a different one previously)

" To add the DKIM record to your DNS, first copy the “Hostname” portion provided in the Set Up For Sending section of the SparkPost UI and paste it in the “Host” section of your DNS TXT record. This value should be similar to scphxxxx._domainkey.yourdomain.xxx . Please note that some providers are particular about the “Host” and may require that the value be added as just scphxxxx._domainkey "

apparently… for namecheap… the value must just be scphxxxx._domainkey

thanks for all the help :slightly_smiling_face: