Stop outbound mail going to a specific domain

For some reason Apple has decided with all its mail domains that mail originating from our Discourse server and out via Amazon SES is spam and bounces it. [It’s an Early Music forum, hardly offensive in any way I don’t think.] This affects our mail reputation badly. Is there any way I can suppress email to a set of given domains, e.g., and so on, while leaving all other outbound mail intact?

1 Like

Sorry, I don’t know, but there is stong history where Amazon and Apple are marking each others mailservers as spam. You can check if your mailserver is marked as spam. If that’s true it will be corrected in a day — unless you are actually relying and your setup is spamming.

1 Like

That is useful to know.

We are most certainly not an open relay, I have checked rigourously.

The cycle I am seeing is that we get Apple bounces solid for about a week or two, then a week of relief, and then back to being bounced. Not a cycle of days, but more like weeks. It’s hopeless, because there is no way to contact Apple about it as far as I know.

1 Like

My plugin can solve this problem.

Just set the discourse_another_smtp_enabling_mails to the domains you want, and keep the other settings at default (which is invalid), you can prevent emails from being sent to these domain names.