Suddenly blank page on Android with version 2.7.2

I use Firefox for Android 68 on Android 9.

Since 2021-06-05, community.metabrainz.org is just a blank page for me, whether logged in or out.
I tried the included Chrome browser, same issue.

Meta however works OK.

MetaBrainz Discourse is Discourse 2.7.2 - https://github.com/discourse/discourse version 81070b323f4679e3052efe64b5db7fecada10f23 which is older than meta Discourse 2.8.0.beta2 - https://github.com/discourse/discourse version 940eb28e31636cf585a27daa92a1e86a14238423.

I tried on an older Android from my office and there it works with Samsung browser. :thinking:

Any clue?

Here are errors that only occur on community.metabrainz.org (blank page):

SyntaxError: expected expression, got '.'
https://community.metabrainz.org/assets/application-b2ca9fbe8bab1b27bb00821fc91900c720b3c6836296c8e6062d44a1ed6d82f2.js

Error: Could not find module discourse/lib/theme-settings-store
https://community.metabrainz.org/assets/_ember_jquery-36a23101c869ab0dc53fc908de69adb785731593573d32bdeef416acc1076ef4.js

ReferenceError: Discourse is not defined
https://community.metabrainz.org/assets/start-discourse-efa4e5abfbd1b50b5152ffbe64d5dcea9f7c33f766dcc6387e2711f0f2112148.js

Update: I removed the Content Security Policy errors that were common to meta.discourse.org and community.metabrainz.org, it was just distracting and irrelevent.

1 Like

Firefox for Android is currently on version 88.1.4, can you reproduce on that? It loads just fine for me on the current version:

Still, neither version is officially supported, as we only support Chrome on Android.

3 Likes

FYI - We have heard similar complaints after updating forums to 2.7.2: mobile site going completely blank. We do not have any specifics about the client OS or browser though.

3 Likes

I know but only 68 does support add-ons (I need Violentmonkey on mobile, to check my CD collection when in second hand shops).

And it is also blank with the built in browser (Chrome).

1 Like

I can’t reproduce that on neither Firefox nor Chrome on my Android phone.

Also opens fine on my desktop.

4 Likes

Ah. Maybe it’s because I’m logged in.
I will try to identify all the possible cases where it works and does not work.

1 Like

Thanks very much for your feedbacks.
Indeed it works with more recent Chrome!

For the record (in bold, my own setup; others are from my job test phones; striked-through browsers have no add-ons support):

Browser Mobile OS community.metabrainz.org status (2.7.3) meta.discourse.org status (2.8.0)
Firefox 68.2.0 Android 5.0.2 :x: :green_circle:
Firefox 68.11.0 Android 9 :x: :green_circle:
Firefox 69+
Chrome 46.0.2490.76 Android 5.0.2 :x: :x:
Chrome 56.0.2924.87 Android 6.0.1 :x: :green_circle:
Chrome 77.0.3865.92 Android 9 :x: :green_circle:
Chrome 91.0.4472.88 Android 5.0.2, Android 6.0.1, Android 9 :green_circle: :green_circle:
Samsung Internet 13.2.3.2 Android 6.0.1 :green_circle: :green_circle:
Samsung Internet 14.0.3.5 Android 6.0.1 :green_circle: :green_circle:
Edge 40.15063.1868.0 Windows 10 :x: :x:

Work-around

As a work-around, I have updated Chrome and installed the Discourse site as a desktop icon / favourite / app? and will use that until community.metabrainz.org (now in version 2.7.3) reaches similar recent version like meta.discourse.org (version 2.8.0) that is again compatible with Firefox for Android 68.11.0. :slight_smile:
Long touch on links allow me to open links in Firefox. Slightly slower but good enough for me.


Associated post at community.metabrainz.org

2 Likes

Bug is being tracked here

4 Likes

Hi @sam,
Discourse version 2.8.0, used here on meta has no issues, so no need to change Discourse code for this issue, I think.
We just wait for version 2.8.0 and it will be fixed.
Meanwhile we use another browser.

1 Like

Well… you’re not the only one suffering from this issue @jesus2099 :slight_smile:

2 Likes

Yes but the mentioned fix would apparently be to serve a static read-only HTML version to those browsers.

So I prefer waiting with no changes, as this more recent version of Discourse, here on meta (2.8.x), does work with those browsers in full featured mode (maybe thanks to transpiration).

1 Like

No, I think you misunderstood.

That was probably not on purpose, but it made me smile :slight_smile:

4 Likes

Super, then! :grin::+1:
I saw the unintentional typo, but then I intentionally left it like that. :wink::face_with_hand_over_mouth:
It will be fixed! Super!

2 Likes