Blank page when using iPhone 6 since last 16th March

I have an iPhone 6 (OS 12.5.5) and since last Wednesday I get a blank page when I navigate to my usual discourse forums using Chrome or Safari.



and even



On the other hand, one forum is still working normally.

Unlike “some-user-see-a-blank-page-when-opening-a-topic/148548” I can’t see anything (no list of topics and no topic contents). If I request desktop site I see some static header links on psychopy dot org but nothing on the other two sites. I get the same behaviour using an incognito tab, which suggests it’s not a cache issue.

I tried installing the discourse app, but since you need to log in for the first time via a web page and I can’t see web pages on the same device, then I am only able to attach the Empire forum to the app.

Any ideas? Did anything change last Wednesday or has my phone had enough?

Looks very likely to be a similar issue to:

We will have a look over the next week. Thanks for reporting.


Thanks. For additional information, I tried installing Opera on my iPhone and have the same issue (only one forum works).

Discourse will now fall back to the basic-html view for browsers which do not support replaceAll


The iOS version of Opera uses the same rendering engine as Safari, just like every other web browser built for iOS.

Also, that one forum is likely on an older version of Discourse.


Since I can’t upgrade my version of iOS or my browsers on my iPhone 6 then whatever upgrade happened last week means that discourse is no longer compatible with my phone. Is there something that can be done to maintain compatibility on a discourse site where I have admin rights, or do I need to buy a new phone?

I’ve notice this error in the logs of both sites, which might be related?

#<NoMethodError: undefined method `host' for nil:NilClass>

Yes, that’s likely what you’ll have to do.

Just would like to let everyone know that I have the same issue.
I have an iPhone 6S running iOS 12.2, which btw I don’t plan on replacing or updating. I am an active user at but since a few days ago I just get a blank page on my phone, whatever browser I use. I have the Discourse Hub app which stopped working.
Recently, I’m only shown the “browser is too old” banner" as shown below:

Will this issue be fixed for iOS <13 users? I don’t want to buy a new phone just to be able to continue using the discourse forum

1 Like

Closing in favor of Discourse not loading on legacy browsers - #30 by Falco

1 Like