Ubuntu 14.04 LTS ships with Docker v0.9.1, as the package
docker.io. The launcher script asks for v0.10.x or above, yet Discourse runs fine under the official docker release by Ubuntu.
I would like to think that 14.04.1 provides a vendor upgrade to Docker 1.0, but for now docker.io does not provide specific instructions for upsteam releases on 14.04. A few Docker cloud providers are beginning their Docker deployment on 14.04 hosts with the vendor supported version of Docker.
If we can avoid breaking support for Docker v0.9.1 in the meantime, I see no reason to have the script allow v0.9.1 and up. A solution is to warn the user about upgrading, rather than terminating the script.
I mistakenly posted this under Github issues rather than here. @supermathie commented that as Docker is still new and moving so quickly, encouragement to stay on the latest version is a good thing. @sam mentioned about a possible regression for his reason for not supporting v0.9.1.