Support Docker v0.9.1 and up

(Dan Porter) #1

Ubuntu 14.04 LTS ships with Docker v0.9.1, as the package The launcher script asks for v0.10.x or above, yet Discourse runs fine under the official docker release by Ubuntu.

I would like to think that 14.04.1 provides a vendor upgrade to Docker 1.0, but for now does not provide specific instructions for upsteam releases on 14.04. A few Docker cloud providers are beginning their Docker deployment on 14.04 hosts with the vendor supported version of Docker.

If we can avoid breaking support for Docker v0.9.1 in the meantime, I see no reason to have the script allow v0.9.1 and up. A solution is to warn the user about upgrading, rather than terminating the script.

I mistakenly posted this under Github issues rather than here. @supermathie commented that as Docker is still new and moving so quickly, encouragement to stay on the latest version is a good thing. @sam mentioned about a possible regression for his reason for not supporting v0.9.1.

(Dan Porter) #2

Regardless of what version of Docker we decide to support, I’ve improved the logic of the launcher script used by Discourse to support both a minimum, and recommended version. Currently, the launcher script will only run with Docker versions containing 0.10 in their string (so 0.10.0, or 1.0.10, but not 0.11.0)

(Jeff Atwood) #3

Is this PR OK @sam? If so let’s pull it in.

(Sam Saffron) #4

Yes totally fine with improvements to the logic.

I am also happy to amend the logic so you can bypass the pre-flight checks. Eg:

./launcher --no-check bootstrap app

This will require quite a few changes internally, but should allow you to simply alias it without needing to fork the launcher script.

I am against supporting 0.9.1 cause you will be in for a shock when your containers stop after upgrading to 0.10, I am fairly confident this will not be fixed with the 0.11 upgrade, the internal design changed in a breaking way.

cc @SvenDowideit

(Kris Williams) #5

Is there any way to downgrade from 0.11 to 0.10? After doing apt-get upgrade lxc-docker it installed 0.11 and totally hosed my docker image.

(Sam Saffron) #6

My priority for today is testing out 0.11 and making sure it is good.

(Sam Saffron) #7

Just updated launcher to detect 0.11 and work with it. Seems to work fine here.

What issues are you seeing?

(Kris Williams) #8

cd /var/docker && git pull && ./launcher stop app && ./launcher start app

root@discourse:/var/docker# docker -v
Docker version 0.11.0, build 15209c3

seems to be good. Thanks Sam!

(Jeff Atwood) #9

I believe the minimum Docker version we support is 1.2 now, and the current version as of this writing is 1.7.