Tagging Korean Words


(Anton) #1

Hello, I’ve been using Discourse as our official forum for my game. And it’s been a great pleasure to use such a sophisticated platform as our forum.

And while using it in Korean, I encountered a tiny problem:

1524805032958

This bug occurs when I try to tag Korean words. As you can see in the picture above, when I try to add a Korean word as a tag, the cursor stays at the start of the textbox.

As for the version I am using, it’s v2.0.0.beta7 +14.

Please feel free to ask for further details if you need any.


(Joffrey Jaffeux) #3

Hi, I’ve been unable to reproduce this on chrome/firefox/edge

can you give me clear reproduction please?


(Kane York) #4

This probably has something to do with a custom IME.


(Stephen Chung) #5

Yes, it is an IME issue. The text box is trapping key down events necessary for the IME to work.

It is the same situation with Chinese. I had to first use a text editor to type the text, then paste into the text box.

It didn’t use to do that in earlier versions.

So i suspect that the text box is not useable for languages requiring an IME.


(Joffrey Jaffeux) #6

Yes I have an idea about this, it’s probably due to some char range. Will investigate.


(Stephen Chung) #9

I have done some experimentation and found out this for CJK:

  • Typing when the “loading” gif is on (i.e. loading the auto-complete list): Doesn’t work. It will jump all over the place, or escape out the IME characters.

  • Typing when the “loading” gif if off (i.e. finished loading the auto-complete list): Works.


(Joffrey Jaffeux) #10

Yes I think I have identified the problematic line, thanks for testing more.


(Joffrey Jaffeux) #11

MIGHT be fixed by (I still can’t reproduce) FIX: allows more chars than a-z in select-kit by jjaffeux · Pull Request #5889 · discourse/discourse · GitHub

I will wait for 2.0 release before merging this though, I’m unsure about some consequences.


(Joffrey Jaffeux) #12

I merged this fix today.


(Joffrey Jaffeux) #13