Text selection is cancelled when the AI popup disappears

When we quickly edit a message, unwanted problems occur in the editor. For example, after selecting a word to make it bold, the selection is canceled when the mouse is hovered over the bold button. This applies to all buttons. For example, when the AI button appears after the selection, the selection is canceled when we hover over it with the mouse.

I made a video so you can understand.

1 Like

yea I noticed it too on Meta recently. I think it’s this again

I get it sometimes using the regular edit, not just quick edit.


I saw your thread before opening this thread but thought it was different. I think it’s because of my naughty English :confused: I only get this error in quick editing. I tried in safe mode. I have the same problem on my own site and meta. I think other sites have this problem too.

1 Like

Hi kuaza!

Thanks for the report.

I can repro it without using the fast edit feature, so I’ve removed the tag.

I think it’s more related to the AI popup. The selection is canceled when the popup disappears.

Edit: I could repro the issue without fast edit, but now I cannot. I think the repro steps need to be more accurately defined.

I think I got it.

  1. Use fast edit but make it open the composer instead of the fast edit popup.

  2. Then, select any text in the composer. The AI helper popup shows up.

  3. Move the cursor to make the AI helper popup disappear, either by hovering this popup and move the cursor away or move the cursor away from the composer text area.

  4. The selection is canceled.

If you close the composer, and edit the post without using the fast selection, the issue remains until you refresh the page.


It does also work without the AI helper
(It also works that way on a discourse site where the plugin is not even installed)


The problem is not related to any plugin or theme. It continues even when you try turning off add-ons in safe mode. I tried with another theme, the problem still persists.

I think this is fixed no? I can’t repro anything from the videos in this topic.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.