The forum is down after clicking on update!

Hi,
Our forum is :
https://forum-vigneux-sur-seine.fr/

Since several hours, the site provides error 500 after receiving a mail for update and accept it.

What happen now?

The message says : it will work again later.
But when?
have I something to do?
Thank you for reply.

Dominique Dutoit

2 Likes

It’s hard to say without more information:

  • which release are you running?
  • which plugins are you using?
  • how did you install this instance?
  • have you attempted to rebuild via command line/ssh?

Recategorising from #bug to #support.

1 Like

Hi Stephen,
It was the last update, 12 hours ago.
Now, it’s working again. @pfaffman did something and sent a mail.
But I 'm afraid to say that I Have no idea about what to do in a next future…

I suppose that I will not update discourse after this.
Thank you very much Stephen and thank you Jay.

:two_hearts:

1 Like

I describe how to upgrade your two-container installation here: Managing a Two-Container Installation - Documentation - Literate Computing Support.

Well, a surprising number of people do that, but it’s not what I’d recommend!

5 Likes

This seems solved so I don’t feel I’ll pollute it,

My site is running but during todays update

and now

and it wont reset even after a log out it still reads

I don’t feel I did it fixed so much as I thought this might assist any other issues,

II did do a hard refresh

1 Like

just logged back in and seen this

got me here

hamburger menu won’t take me to admin so I typed admin in the url,

site shows me logged in but page reads

2 Likes

I had the exact same issue and followed advice from @pfaffman on this thread. All you need to do is logon to the server as root and do a pull and rebuild of the app and it will all be fixed:

cd /var/discourse
git pull; ./launcher rebuild app

Of course, the bigger question is why a few of us are having this exact same issue (including the hamburger not working and then the admin page giving a does not exist error) during upgrades when it has never happened before?

5 Likes

Same with my forum.

I fixed with:

cd /var/discourse
git pull
./launcher rebuild app

Please check out all the categories, with your URL: your-forum.com/categories, do you see all of these?

In my case, I see some. Not all of it. I’m investing why.

1 Like

I’m sure I have more

I just did a back-up expecting I was on my own but when I tackle this later I’ll look for that :+1:

Thanks my brothers!

1 Like

I just made and deleted a post about this exact issue (this thread didn’t show up when I was searching topics).

I normally upgrade from the command line but don’t have my computer with me today and did the upgrade via the UI. I guess I’ll avoid that in the future.

I guess I will do this later tonight…

I was also having Sidekiq errors and emails not being sent out. Did anyone else have those?

1 Like

This did solve part of my problems; although, I’m still having issues with Sidekiq.

1 Like

We had a temporary window a few days ago where sidekiq was doing this, I recommend you upgrade again.

6 Likes

Thanks. That worked. No more errors.

3 Likes